summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2021-06-01 20:23:03 +0000
committerJulien Lepiller <julien@lepiller.eu>2021-06-06 17:17:22 +0200
commit52dc188e12fe80dfe13ba04f995081beedde6358 (patch)
treeb8aacb86bcb91953ba85d9744a3a05f10bfafbac /gnu/packages/ocaml.scm
parent7cf518ee8506ae5e5ff2c7846ca402b88de78c27 (diff)
downloadguix-patches-52dc188e12fe80dfe13ba04f995081beedde6358.tar
guix-patches-52dc188e12fe80dfe13ba04f995081beedde6358.tar.gz
gnu: Add ocaml-ppx-cold.
* gnu/packages/ocaml.scm (ocaml-ppx-cold): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 79537bfa93..2b4673882b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5637,6 +5637,28 @@ match expressions, and if expressions.")
position.")
(license license:asl2.0)))
+(define-public ocaml-ppx-cold
+ (package
+ (name "ocaml-ppx-cold")
+ (version "0.14.0")
+ (home-page "https://github.com/janestreet/ppx_cold")
+ (source
+ (janestreet-origin "ppx_cold" version
+ "1madfzhpir9amnxmg530n70vll0jrl59vyp71miji73i6b9sy6n2"))
+ (build-system dune-build-system)
+ (arguments `(#:test-target "tests"))
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_cold")))
+ (synopsis "Syntax extension for indicating cold path")
+ (description
+ "This package contains an syntax extension to indicate that the code is
+on the cold path and should be kept out of the way to avoid polluting the
+instruction cache on the hot path. See also
+https://github.com/ocaml/ocaml/issues/8563.")
+ (license license:expat)))
+
(define-public ocaml4.07-ppx-assert
(package
(name "ocaml4.07-ppx-assert")