summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2021-06-01 20:23:19 +0000
committerJulien Lepiller <julien@lepiller.eu>2021-06-13 17:15:43 +0200
commit40d6c7aada5e07e352a81adc9b4004fb22f39d8a (patch)
tree28b66a1e3262b537dd32a977d0eb26a347e2f319 /gnu/packages/ocaml.scm
parent1daf62b940dc57071844741142ca4e8ed0be802e (diff)
downloadguix-patches-40d6c7aada5e07e352a81adc9b4004fb22f39d8a.tar
guix-patches-40d6c7aada5e07e352a81adc9b4004fb22f39d8a.tar.gz
gnu: Add ocaml-uri.
* gnu/packages/ocaml.scm (ocaml-uri): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8b60def7f7..13ebafdd01 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3415,6 +3415,35 @@ the need to write signal code, which is useful for quick scripts that manipulate
JSON.")
(license license:isc)))
+(define-public ocaml-uri
+ (package
+ (name "ocaml-uri")
+ (version "4.1.0")
+ (home-page "https://github.com/mirage/ocaml-uri")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "10bf28my1yhj8a2d7bkgbna9j20wq0ghp92k926y29bmjj2qh0l7"))))
+ (build-system dune-build-system)
+ (arguments '(#:package "uri"
+ #:test-target "."))
+ (propagated-inputs
+ `(("ocaml-stringext" ,ocaml-stringext)
+ ("ocaml-angstrom" ,ocaml-angstrom)))
+ (native-inputs
+ `(("ocaml-ounit" ,ocaml-ounit)
+ ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)))
+ (properties `((upstream-name . "uri")
+ (ocaml4.07-variant ,(delay ocaml4.07-uri))))
+ (synopsis "RFC3986 URI/URL parsing library")
+ (description "OCaml-uri is a library for parsing URI/URL in the RFC3986 format.")
+ (license license:isc)))
+
(define-public ocaml4.07-uri
(package
(name "ocaml4.07-uri")
@@ -3447,6 +3476,7 @@ JSON.")
`(("ocaml-re" ,(package-with-ocaml4.07 ocaml-re))
("ocaml-sexplib0" ,(package-with-ocaml4.07 ocaml-sexplib0))
("ocaml-stringext" ,(package-with-ocaml4.07 ocaml-stringext))))
+ (properties `((upstream-name . "uri")))
(home-page "https://github.com/mirage/ocaml-uri")
(synopsis "RFC3986 URI/URL parsing library")
(description "OCaml-uri is a library for parsing URI/URL in the RFC3986 format.")