summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-19 17:50:32 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-06-20 02:12:40 +0200
commit376b16e9a180ddef1aca795a3acf2512561976ef (patch)
treed78549d428cfe6ab66b3df74216aa47e245ada04 /gnu/packages/ocaml.scm
parentacb34cda237b462c6872cb698f5fc4123550d77c (diff)
downloadguix-patches-376b16e9a180ddef1aca795a3acf2512561976ef.tar
guix-patches-376b16e9a180ddef1aca795a3acf2512561976ef.tar.gz
gnu: Add ocaml-pcre.
* gnu/packages/ocaml.scm (ocaml-pcre): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4510affe0f..a6637c83ff 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3086,6 +3086,38 @@ every compliant installation of OCaml and organize these libraries into a
hierarchy of modules.")
(license license:lgpl2.1+)))
+(define-public ocaml-pcre
+ (package
+ (name "ocaml-pcre")
+ (version "7.4.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mmottl/pcre-ocaml")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "11mck879p5zvkghps4ky8yslm0isgz52d84adl0dmcfxv2ibvcym"))))
+ (build-system dune-build-system)
+ (arguments
+ ;; No tests.
+ '(#:tests? #f))
+ (propagated-inputs
+ `(("dune-configurator" ,dune-configurator)
+ ("pcre" ,pcre)))
+ (native-inputs
+ `(("pcre:bin" ,pcre "bin")))
+ (home-page "https://mmottl.github.io/pcre-ocaml")
+ (synopsis
+ "Bindings to the Perl Compatibility Regular Expressions library")
+ (description "Pcre-ocaml offers library functions for string
+pattern matching and substitution, similar to the functionality
+offered by the Perl language.")
+ ;; With static linking exception
+ (license license:lgpl2.1+)))
+
(define-public ocaml4.07-pcre
(package
(name "ocaml4.07-pcre")