summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2020-12-28 22:10:08 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-12-30 14:25:58 +0100
commit349699bbc21c9946486b0b41d8b2e24192bc9b7a (patch)
tree1e74d0ed5aecfbbecb358cee103227913940dde9 /gnu/packages/ocaml.scm
parent5de771a49a52ff56ddaec4a911cb44b9d41d31fa (diff)
downloadguix-patches-349699bbc21c9946486b0b41d8b2e24192bc9b7a.tar
guix-patches-349699bbc21c9946486b0b41d8b2e24192bc9b7a.tar.gz
gnu: Add ocaml-ounit2.
* gnu/packages/ocaml.xyz (ocaml-ounit2): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b12a795e47..d10b14bf37 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -982,6 +982,32 @@ compilers that can directly deal with packages.")
`(("m4" ,m4)
("ocaml" ,ocaml-4.09)))))
+(define-public ocaml-ounit2
+ (package
+ (name "ocaml-ounit2")
+ (version "2.2.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gildor478/ounit.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gxjw1bhmjcjzri6x6psqrkbbyq678b69bqfl9i1zswp7cj2lryg"))))
+ (build-system dune-build-system)
+ (inputs
+ ;; XXX Should libev be a propagated-input of ocaml-lwt?
+ `(("libev" ,libev)))
+ (propagated-inputs
+ `(("lwt" ,ocaml-lwt)
+ ("ocaml-stdlib-shims" ,ocaml-stdlib-shims)))
+ (home-page "https://github.com/gildor478/ounit")
+ (synopsis "Unit testing framework for OCaml")
+ (description "OUnit2 is a unit testing framework for OCaml. It is similar
+to JUnit and other XUnit testing frameworks.")
+ (license license:expat)))
+
;; note that some tests may hang for no obvious reason.
(define-public ocaml-ounit
(package