summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-11-22 21:02:59 -0600
committerBrett Gilio <brettg@gnu.org>2020-11-22 21:02:59 -0600
commit0ada181aa1a3a675a1d189744429665e0f4cb301 (patch)
tree843f56956f3ced42e84ad32593a35c4b0c6f52c0 /gnu/packages/ocaml.scm
parent12ed211b7583f8f57e5502759cd263a49b5e142f (diff)
downloadguix-patches-0ada181aa1a3a675a1d189744429665e0f4cb301.tar
guix-patches-0ada181aa1a3a675a1d189744429665e0f4cb301.tar.gz
gnu: ocaml-cairo2: Patch test phase.
* gnu/local.mk (ocaml-cairo2-caml_ba_array_fix.patch): Add ref. * gnu/packages/ocaml.scm (ocaml-cairo2): Utilize patch. * gnu/packages/patches/ocaml-cairo2-caml_ba_array-fix.patch: Add file.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 706def4f43..369e819573 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5797,16 +5797,18 @@ convenience functions for vectors and matrices.")
(url "https://github.com/Chris00/ocaml-cairo")
(commit version)))
(file-name (git-file-name name version))
+ (patches
+ (search-patches
+ ;; NOTE: This patch will be obsolete on the
+ ;; next tagged release. Remove it at that
+ ;; point.
+ "ocaml-cairo2-caml_ba_array-fix.patch"))
(sha256
(base32
"0wzysis9fa850s68qh8vrvqc6svgllhwra3kzll2ibv0wmdqrich"))))
(build-system dune-build-system)
(arguments
- `(;; NOTE: GC reclaims bigarrays packed into a custom structure
- ;; regardless of their refcounts. Affects OCaml >= 4.10.x
- ;; https://github.com/ocaml/ocaml/issues/9360
- #:tests? #f
- #:test-target "tests"))
+ `(#:test-target "tests"))
(inputs
`(("cairo" ,cairo)
("gtk+-2" ,gtk+-2)