summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-09-30 23:47:30 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-10-15 18:00:53 +0200
commit01ec666e6c17759e78239cee7005fb2a6f72ab86 (patch)
tree2576a81f98561c44a8890c2edab158aa878c1cdd /gnu/packages/ocaml.scm
parent0a86b93fae09dbc1b76d293bd1c4c02fb1a737b7 (diff)
downloadguix-patches-01ec666e6c17759e78239cee7005fb2a6f72ab86.tar
guix-patches-01ec666e6c17759e78239cee7005fb2a6f72ab86.tar.gz
gnu: ocaml-alcotest: Update to 1.0.0.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ac0ee2b888..811402440e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1659,14 +1659,14 @@ immutability.")
(define-public ocaml-alcotest
(package
(name "ocaml-alcotest")
- (version "0.8.5")
+ (version "1.0.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mirage/alcotest/releases/"
"download/" version "/alcotest-" version ".tbz"))
(sha256
(base32
- "0szwjxvaahgynsx0apj81jxj3ki6yz4is9mh2wkcbx66qy7n6fvb"))))
+ "1a43ilhwnj58pq3bi78ni46l9wh6klmmgfc93i94mvyx48bzzayx"))))
(build-system dune-build-system)
(arguments
`(#:package "alcotest"
@@ -1677,8 +1677,10 @@ immutability.")
`(("ocaml-astring" ,ocaml-astring)
("ocaml-cmdliner" ,ocaml-cmdliner)
("ocaml-fmt" ,ocaml-fmt)
- ("ocaml-result" ,ocaml-result)
- ("ocaml-uuidm" ,ocaml-uuidm)))
+ ("ocaml-re" ,ocaml-re)
+ ("ocaml-stdlib-shims" ,ocaml-stdlib-shims)
+ ("ocaml-uuidm" ,ocaml-uuidm)
+ ("ocaml-uutf" ,ocaml-uutf)))
(home-page "https://github.com/mirage/alcotest")
(synopsis "Lightweight OCaml test framework")
(description "Alcotest exposes simple interface to perform unit tests. It