summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-09-06 18:52:51 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-09-08 23:15:31 +0900
commitf92cf9d356e5584b073a626bcb27ffb5ed7f99a7 (patch)
tree60568ed0922b0f1e5d59ec967f6e2d5164e988c5 /gnu/packages/ntp.scm
parent5658ae8a0ad5d988765944b7e783b2bdc23a7f48 (diff)
downloadguix-patches-f92cf9d356e5584b073a626bcb27ffb5ed7f99a7.tar
guix-patches-f92cf9d356e5584b073a626bcb27ffb5ed7f99a7.tar.gz
gnu: openntpd: Fix error CA errors when using constraints.
The error printed by nttpd was "constraint: failed to load constraint ca" when libressl tried loading the file /etc/ssl/cert.pem. The problem was investigated as part of fixing issue 37318 (see: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=37318). * gnu/packages/ntp.scm (openntpd)[configure-flags]: Use the '--with-cacert' flag to specify the location of the certificate authority file of libressl.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 419b6d7321..6942ecec2f 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2015, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -108,8 +109,11 @@ computers over a network.")
"0fn12i4kzsi0zkr4qp3dp9bycmirnfapajqvdfx02zhr4hanj0kv"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--with-privsep-user=ntpd"
- "--localstatedir=/var")
+ '(#:configure-flags `( "--with-privsep-user=ntpd"
+ "--localstatedir=/var"
+ ,(string-append "--with-cacert="
+ (assoc-ref %build-inputs "libressl")
+ "/etc/ssl/cert.pem"))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'modify-install-locations