summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-28 13:53:37 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-29 15:25:23 +0200
commitefc1fd32880e7936ff5dc29e472cb26763559637 (patch)
tree9cd846124e6fc21b943ce7d228c26b378419c920 /gnu/packages/ntp.scm
parented615bcd14763acc3ba4b18fbadb5ce2acd40868 (diff)
downloadguix-patches-efc1fd32880e7936ff5dc29e472cb26763559637.tar
guix-patches-efc1fd32880e7936ff5dc29e472cb26763559637.tar.gz
gnu: tlsdate: Return #t from phases.
* gnu/packages/ntp.scm (tlsdate)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index e9ae9fa466..24653a235b 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -164,7 +165,7 @@ minimalist than ntpd.")
;; "recent date" since it is used to detect bogus dates
;; received from servers.
(setenv "COMPILE_DATE" (number->string 1450563040))
- (zero? (system* "sh" "autogen.sh")))))))
+ (invoke "sh" "autogen.sh"))))))
(inputs `(("openssl" ,openssl)
("libevent" ,libevent)))
(native-inputs `(("pkg-config" ,pkg-config)