summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-18 23:25:15 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 16:04:58 +0200
commitc1947a8c7df950d19d10df44e683b8860b14b321 (patch)
treeb7eb12a0363a0e3cb61ffc7623bb220dee15b315 /gnu/packages/ntp.scm
parent7003b2db526fc367664f3a7c4bdbe38a7c717da6 (diff)
downloadguix-patches-c1947a8c7df950d19d10df44e683b8860b14b321.tar
guix-patches-c1947a8c7df950d19d10df44e683b8860b14b321.tar.gz
gnu: ntp: Prepare for GCC 10.
* gnu/packages/ntp.scm (ntp)[source](patches): New field.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index ecad2854a7..b86def1929 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -122,6 +123,16 @@ time-stamping or reference clock, sub-microsecond accuracy is possible.")
"/ntp-" version ".tar.gz")))
(sha256
(base32 "06cwhimm71safmwvp6nhxp6hvxsg62whnbgbgiflsqb8mgg40n7n"))
+ ;; Add an upstream patch to fix build with GCC 10. Taken from
+ ;; <https://bugs.ntp.org/show_bug.cgi?id=3688>.
+ (patches (list (origin
+ (method url-fetch)
+ (uri "https://bugs.ntp.org/attachment.cgi?id=1760\
+&action=diff&context=patch&collapsed=&headers=1&format=raw")
+ (file-name "ntp-gcc-compat.patch")
+ (sha256
+ (base32
+ "13d28sg45rflc7kqiv30asrhna8n69wlpwx16l65rravgpvp90h2")))))
(modules '((guix build utils)))
(snippet
'(begin