summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/ntp.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 55b9a73b22..e93e947929 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -80,12 +80,9 @@
(copy-recursively "examples" (string-append doc "/examples"))
#t))))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("gnutls" ,gnutls)
- ("libcap" ,libcap)
- ("libseccomp" ,libseccomp)
- ("nettle" ,nettle)))
+ (list gnutls libcap libseccomp nettle))
(home-page "https://chrony.tuxfamily.org/")
(synopsis "System clock synchronisation service that speaks NTP")
(description
@@ -147,8 +144,7 @@ time-stamping or reference clock, sub-microsecond accuracy is possible.")
(rename-file "sntp/libevent:build-aux"
"sntp/libevent/build-aux")
#t))))
- (native-inputs `(("which" ,which)
- ("pkg-config" ,pkg-config)))
+ (native-inputs (list which pkg-config))
(inputs
`(("openssl" ,openssl)
("libevent" ,libevent)
@@ -207,7 +203,7 @@ computers over a network.")
(("DESTDIR\\)\\$\\(localstatedir") "TMPDIR"))
#t)))))
(inputs
- `(("libressl" ,libressl))) ; enable TLS time constraints. See ntpd.conf(5).
+ (list libressl)) ; enable TLS time constraints. See ntpd.conf(5).
(home-page "http://www.openntpd.org/")
(synopsis "NTP client and server by the OpenBSD Project")
(description "OpenNTPD is the OpenBSD Project's implementation of a client