summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-25 00:17:39 -0500
committerMark H Weaver <mhw@netris.org>2014-12-25 00:19:36 -0500
commit53a427cf20e460368ca1499d40b63f241bcd42a5 (patch)
tree4ff92c54b4cb62f1c31bb3e621e24ef97ce79fdc /gnu/packages/ntp.scm
parent764c077b307f0a9cdc800494da552077d6d23895 (diff)
downloadguix-patches-53a427cf20e460368ca1499d40b63f241bcd42a5.tar
guix-patches-53a427cf20e460368ca1499d40b63f241bcd42a5.tar.gz
gnu: ntp: Update to 4.2.8.
* gnu/packages/ntp.scm (ntp): Update to 4.2.8. Add openssl to inputs. Add pkg-config to native-inputs. Change source URI to archive.ntp.org.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm34
1 files changed, 20 insertions, 14 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 8e6ed4fd3c..b2c520605a 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,8 +21,11 @@
#:use-module (gnu packages)
#:use-module (gnu packages which)
#:use-module (gnu packages linux)
- #:use-module (guix licenses)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages openssl)
+ #:use-module ((guix licenses) #:prefix l:)
#:use-module (guix packages)
+ #:use-module (guix utils)
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (srfi srfi-1))
@@ -29,29 +33,31 @@
(define-public ntp
(package
(name "ntp")
- (version "4.2.6p5")
+ (version "4.2.8")
(source (origin
(method url-fetch)
(uri (string-append
- "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-"
- (string-join (take (string-split version #\.) 2) ".")
+ "http://archive.ntp.org/ntp4/ntp-"
+ (version-major+minor version)
"/ntp-" version ".tar.gz"))
(sha256
(base32
- "077r69a41hasl8zf5c44km7cqgfhrkaj6a4jnr75j7nkz5qq7ayn"))))
- (native-inputs `(("which" ,which)))
+ "1vnqa1542d01xmlkw8f3rq57y360b2j7yxkkg9b11955nvw0v4if"))))
+ (native-inputs `(("which" ,which)
+ ("pkg-config" ,pkg-config)))
(inputs
- ;; Build with POSIX capabilities support on GNU/Linux. This allows 'ntpd'
- ;; to run as non-root (when invoked with '-u'.)
- (if (string-suffix? "-linux"
- (or (%current-target-system) (%current-system)))
- `(("libcap" ,libcap))
- '()))
+ `(("openssl" ,openssl)
+ ;; Build with POSIX capabilities support on GNU/Linux. This allows 'ntpd'
+ ;; to run as non-root (when invoked with '-u'.)
+ ,@(if (string-suffix? "-linux"
+ (or (%current-target-system) (%current-system)))
+ `(("libcap" ,libcap))
+ '())))
(build-system gnu-build-system)
(synopsis "Real time clock synchonization system")
(description "NTP is a system designed to synchronize the clocks of
computers over a network.")
- (license (x11-style
+ (license (l:x11-style
"http://www.eecis.udel.edu/~mills/ntp/html/copyright.html"
"A non-copyleft free licence from the University of Delaware"))
(home-page "http://www.ntp.org")))