summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-09 21:39:41 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-10 10:50:57 +0100
commit4ee696247b320144c16656fd525b20a3a4cf31d3 (patch)
treea005d6163dd2877f0367587759d47db84e8c70a2 /gnu/packages/ntp.scm
parentd02f2cc48c8d74c0350f7a5508766fed2391105c (diff)
downloadguix-patches-4ee696247b320144c16656fd525b20a3a4cf31d3.tar
guix-patches-4ee696247b320144c16656fd525b20a3a4cf31d3.tar.gz
gnu: Add openntpd.
* gnu/packages/ntp.scm (openntpd): New variable.
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 24ce2f564d..0525882b4f 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -61,3 +62,26 @@ computers over a network.")
"http://www.eecis.udel.edu/~mills/ntp/html/copyright.html"
"A non-copyleft free licence from the University of Delaware"))
(home-page "http://www.ntp.org")))
+
+(define-public openntpd
+ (package
+ (name "openntpd")
+ (version "5.7p3")
+ (source (origin
+ (method url-fetch)
+ ;; XXX Use mirror://openbsd
+ (uri (string-append
+ "http://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/openntpd-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0filjmb3b8rc39bvhm8q2azzj10ljfgq41qih71pxv919j57qhag"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.openntpd.org/")
+ (synopsis "NTP client and server by the OpenBSD Project")
+ (description "OpenNTPD is the OpenBSD Project's implementation of a client
+and server for the Network Time Protocol. Its design goals include being
+secure, easy to configure, and accurate enough for most purposes, so it's more
+minimalist than ntpd.")
+ ;; A few of the source files are under bsd-3.
+ (license (list l:isc l:bsd-3))))