summaryrefslogtreecommitdiff
path: root/gnu/packages/nss.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-11 22:38:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-11 22:38:24 +0100
commitb7bf02a418e946b610ef68e8c5131f2350835956 (patch)
tree6d84387279b9870dc0b151bb9d3dce7f9d9de73d /gnu/packages/nss.scm
parent233c1be0a30846f6646b1f4edc6257037d0835fc (diff)
parent13efb24850bc40fab2448771c87c77c9a69fc231 (diff)
downloadguix-patches-b7bf02a418e946b610ef68e8c5131f2350835956.tar
guix-patches-b7bf02a418e946b610ef68e8c5131f2350835956.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/nss.scm')
-rw-r--r--gnu/packages/nss.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 6ed197b578..518739465d 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -34,7 +34,7 @@
(define-public nspr
(package
(name "nspr")
- (version "4.22")
+ (version "4.24")
(source (origin
(method url-fetch)
(uri (string-append
@@ -42,7 +42,7 @@
version "/src/nspr-" version ".tar.gz"))
(sha256
(base32
- "0c6ljv3bdqhc169srbpjy0cs52xk715p04zy08rcjvl54k6bdr69"))))
+ "1l0ksiny032jijgk0g76wf0kiq673i01izj7jrs2h5d1yq6rm9ch"))))
(build-system gnu-build-system)
(native-inputs
`(("perl" ,perl)))
@@ -70,7 +70,7 @@ in the Mozilla clients.")
(define-public nss
(package
(name "nss")
- (version "3.46.1")
+ (version "3.48")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -81,10 +81,9 @@ in the Mozilla clients.")
"nss-" version ".tar.gz")))
(sha256
(base32
- "0l9ns44rlkp1bpblplspfbqmyhb8rhvc89y56kqh725rgpny1xrv"))
+ "1b7qs1q7jqhw9dvkdznanzhc5dyq4bwx0biywszy3qx4hqm8571z"))
;; Create nss.pc and nss-config.
- (patches (search-patches "nss-CVE-2019-11745.patch"
- "nss-pkgconfig.patch"
+ (patches (search-patches "nss-pkgconfig.patch"
"nss-freebl-stubs.patch"
"nss-increase-test-timeout.patch"))))
(build-system gnu-build-system)
@@ -131,7 +130,7 @@ in the Mozilla clients.")
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
;; work around that, set the time to roughly the release date.
- (invoke "faketime" "2019-10-01" "./nss/tests/all.sh")))
+ (invoke "faketime" "2019-12-01" "./nss/tests/all.sh")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))