summaryrefslogtreecommitdiff
path: root/gnu/packages/nss.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-12 04:14:40 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-12 04:14:40 +0200
commit2c267e630086caaa141957ddd9cdf14205b2759c (patch)
tree45d39544b52a6a42cd3326364161b01a3a7db138 /gnu/packages/nss.scm
parentc9e676d0b141f510c19e26edb1e6fad079b9b502 (diff)
downloadguix-patches-2c267e630086caaa141957ddd9cdf14205b2759c.tar
guix-patches-2c267e630086caaa141957ddd9cdf14205b2759c.tar.gz
gnu: nss: Ungraft.
* gnu/packages/nss.scm (nss)[replacement]: Remove field. [source]: Add patch. (nss/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/nss.scm')
-rw-r--r--gnu/packages/nss.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 4f421f6e9d..6ed197b578 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -71,7 +71,6 @@ in the Mozilla clients.")
(package
(name "nss")
(version "3.46.1")
- (replacement nss/fixed)
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -84,7 +83,8 @@ in the Mozilla clients.")
(base32
"0l9ns44rlkp1bpblplspfbqmyhb8rhvc89y56kqh725rgpny1xrv"))
;; Create nss.pc and nss-config.
- (patches (search-patches "nss-pkgconfig.patch"
+ (patches (search-patches "nss-CVE-2019-11745.patch"
+ "nss-pkgconfig.patch"
"nss-freebl-stubs.patch"
"nss-increase-test-timeout.patch"))))
(build-system gnu-build-system)
@@ -184,11 +184,3 @@ applications. Applications built with NSS can support SSL v2 and v3, TLS,
PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509 v3 certificates, and other
security standards.")
(license license:mpl2.0)))
-
-(define nss/fixed
- (package
- (inherit nss)
- (source (origin
- (inherit (package-source nss))
- (patches (append (search-patches "nss-CVE-2019-11745.patch")
- (origin-patches (package-source nss))))))))