summaryrefslogtreecommitdiff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-10 21:34:27 +0100
committerMarius Bakke <marius@gnu.org>2022-01-11 18:36:37 +0100
commitebc097699ca6b01412e93fb41d236b9b73bcc038 (patch)
tree6a3a5772e6347a30b793c6ee4939e567f8c6d4cd /gnu/packages/node.scm
parent5b8af1a592a3c958b56a6bcc9b5bd9c897430c2c (diff)
downloadguix-patches-ebc097699ca6b01412e93fb41d236b9b73bcc038.tar
guix-patches-ebc097699ca6b01412e93fb41d236b9b73bcc038.tar.gz
gnu: node: Disable flaky test.
* gnu/packages/node.scm (node, node-lts)[arguments]: Delete flaky test.
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 5ec54b52eb..587b66f8c2 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2018-2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020, 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
@@ -153,6 +153,10 @@
;; This requires a DNS resolver.
(delete-file "test/parallel/test-dns.js")
+ ;; This test is timing-sensitive, and fails sporadically on
+ ;; slow, busy, or even very fast machines.
+ (delete-file "test/parallel/test-fs-utimes.js")
+
;; FIXME: This test fails randomly:
;; https://github.com/nodejs/node/issues/31213
(delete-file "test/parallel/test-net-listen-after-destroying-stdin.js")
@@ -812,6 +816,10 @@ source files.")
;; These tests require networking.
(delete-file "test/parallel/test-https-agent-unref-socket.js")
+ ;; This test is timing-sensitive, and fails sporadically on
+ ;; slow, busy, or even very fast machines.
+ (delete-file "test/parallel/test-fs-utimes.js")
+
;; FIXME: This test fails randomly:
;; https://github.com/nodejs/node/issues/31213
(delete-file "test/parallel/test-net-listen-after-destroying-stdin.js")