summaryrefslogtreecommitdiff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-24 22:16:27 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-26 02:17:03 +0200
commit5112238fd67106605d578f7f16e54b836c8cf732 (patch)
treeb231206d6c0603d814143507794201e2cf461340 /gnu/packages/node.scm
parentd64b79fa9801d4db6dbfc6aefcb5d773309f72f1 (diff)
downloadguix-patches-5112238fd67106605d578f7f16e54b836c8cf732.tar
guix-patches-5112238fd67106605d578f7f16e54b836c8cf732.tar.gz
gnu: node: Return #t from all phases.
* gnu/packages/node.scm (node)[arguments]: Substitute INVOKE for SYSTEM*.
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 1a79066eac..684afb24a6 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -64,7 +65,7 @@
"deps/uv"
"deps/zlib"))
(substitute* "Makefile"
- ;; Remove references to bundled software
+ ;; Remove references to bundled software.
(("deps/http_parser/http_parser.gyp") "")
(("deps/uv/include/\\*.h") "")
(("deps/uv/uv.gyp") "")
@@ -138,10 +139,10 @@
;; Node's configure script expects the CC environment variable to
;; be set.
(setenv "CC" (string-append (assoc-ref inputs "gcc") "/bin/gcc"))
- (zero? (apply system*
- (string-append (assoc-ref inputs "python")
- "/bin/python")
- "configure" flags)))))
+ (apply invoke
+ (string-append (assoc-ref inputs "python")
+ "/bin/python")
+ "configure" flags))))
(add-after 'patch-shebangs 'patch-npm-shebang
(lambda* (#:key outputs #:allow-other-keys)
(let* ((bindir (string-append (assoc-ref outputs "out")