summaryrefslogtreecommitdiff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2017-07-27 17:11:08 +0200
committerJelle Licht <jlicht@fsfe.org>2017-09-02 22:59:18 +0200
commit448339709d85b77e89651a2f4facf57e31c79b4a (patch)
tree8565df78773c4c5ea3dabb93bd9d44af2338a270 /gnu/packages/node.scm
parent4da9beab14a21040afd8c0deb8c4f5a3576b6933 (diff)
downloadguix-patches-448339709d85b77e89651a2f4facf57e31c79b4a.tar
guix-patches-448339709d85b77e89651a2f4facf57e31c79b4a.tar.gz
gnu: node: Update to 8.4.0.
* gnu/packages/patches/node-9077.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/node.scm (node): Update to 8.4.0. (node)[arguments]: Removed broken linter test. Removed dns test.
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 2cebabbcaf..805b81bd2e 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -40,16 +40,14 @@
(define-public node
(package
(name "node")
- (version "8.1.2")
+ (version "8.4.0")
(source (origin
(method url-fetch)
(uri (string-append "http://nodejs.org/dist/v" version
"/node-v" version ".tar.gz"))
(sha256
(base32
- "0l92gar1pivzaiwffiiiz2f2m5k39sl5fphlfnvy0ml9hrjb65yp"))
- ;; https://github.com/nodejs/node/pull/9077
- (patches (search-patches "node-9077.patch"))))
+ "1vrpc4lspm33hmb8c2q4w1fzg3iaip2gx4wpr4nyy417hbx1a6k4"))))
(build-system gnu-build-system)
(arguments
;; TODO: Purge the bundled copies from the source.
@@ -78,10 +76,9 @@
(("'/usr/bin/env'")
(string-append "'" (which "env") "'")))
- ;; Having the build fail because of linter errors is insane!
+ ;; Linting is no longer supported in the release tarball
(substitute* '("Makefile")
- ((" \\$\\(MAKE\\) jslint") "")
- ((" \\$\\(MAKE\\) cpplint\n") ""))
+ ((" \\$\\(MAKE\\) lint") ""))
;; FIXME: This test seems to depends on files that are not
;; available in the bundled v8. See
@@ -95,6 +92,7 @@
"test/parallel/test-util-inspect.js"
"test/parallel/test-v8-serdes.js"
"test/parallel/test-dgram-membership.js"
+ "test/parallel/test-dns-resolveany.js"
"test/parallel/test-cluster-master-error.js"
"test/parallel/test-cluster-master-kill.js"
"test/parallel/test-npm-install.js"