summaryrefslogtreecommitdiff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2021-03-30 01:27:38 -0400
committerJelle Licht <jlicht@fsfe.org>2021-04-02 18:04:23 +0200
commit2780cea3f8b90d7feb3e21b92b9637abdaa58a76 (patch)
tree8a064e91693ec338dd0add991c1e6f3a30139f23 /gnu/packages/node.scm
parent2cc5883b2149d09cad5d2fe04cf8f7c6e73a0ade (diff)
downloadguix-patches-2780cea3f8b90d7feb3e21b92b9637abdaa58a76.tar
guix-patches-2780cea3f8b90d7feb3e21b92b9637abdaa58a76.tar.gz
gnu: Add node-debug-bootstrap.
* gnu/packages/node.scm (node-debug-bootstrap): New variable.
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 21d6052c06..6c4c02265d 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -303,6 +303,36 @@ formats to milliseconds.")
(description "This package is a binary search function for Node.js.")
(license license:cc0)))
+(define-public node-debug-bootstrap
+ (package
+ (name "node-debug")
+ (version "4.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/visionmedia/debug.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08g52r1d4yqcsfdfb7n5if33d4cghaq75gx5n9hj6m6fd8jfp2pi"))))
+ (build-system node-build-system)
+ (arguments
+ `(#:node ,node-bootstrap
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs `(("node-ms" ,node-ms-bootstrap)))
+ (home-page "https://github.com/visionmedia/debug#readme")
+ (properties '((hidden? . #t)))
+ (synopsis "Small debugging utility")
+ (description "This package contains a tiny JavaScript debugging
+utility modelled after Node.js core's debugging technique. It works in
+Node.js and web browsers.")
+ (license license:expat)))
+
(define-public libnode
(package/inherit node
(name "libnode")