summaryrefslogtreecommitdiff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2020-08-27 02:53:45 +0100
committerPierre Langlois <pierre.langlois@gmx.com>2020-09-04 12:04:43 +0100
commit235093fec0daf3563e21036d74c250d4770ffc77 (patch)
tree1c96fe4dc0a35edaf2f3052ffb023908f9478ab9 /gnu/packages/node.scm
parent852ae64e11ef9107afabbdb307770f946376addd (diff)
downloadguix-patches-235093fec0daf3563e21036d74c250d4770ffc77.tar
guix-patches-235093fec0daf3563e21036d74c250d4770ffc77.tar.gz
gnu: node: Update 10.22.0.
* gnu/packages/node.scm (node): Update to 10.22.0. [inputs]: Replace nghttp2 with nghttp2-1.41.
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 1adb2cd07f..ed0b5c4f16 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -46,14 +47,14 @@
(define-public node
(package
(name "node")
- (version "10.19.0")
+ (version "10.22.0")
(source (origin
(method url-fetch)
(uri (string-append "https://nodejs.org/dist/v" version
"/node-v" version ".tar.xz"))
(sha256
(base32
- "0sginvcsf7lrlzsnpahj4bj1f673wfvby8kaxgvzlrbb7sy229v2"))
+ "1nz18fa550li10r0kzsm28c2rvvq61nq8bqdygip0rmvbi2paxg0"))
(modules '((guix build utils)))
(snippet
`(begin
@@ -185,7 +186,7 @@
("http-parser" ,http-parser)
("icu4c" ,icu4c)
("libuv" ,libuv)
- ("nghttp2" ,nghttp2 "lib")
+ ("nghttp2" ,nghttp2-1.41 "lib")
("openssl" ,openssl)
("zlib" ,zlib)))
(synopsis "Evented I/O for V8 JavaScript")