summaryrefslogtreecommitdiff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2017-05-22 20:03:20 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-23 17:55:59 +0200
commit1fdb883082385ac8c9200b831630bea069f2945d (patch)
tree7621887b1975c9a380124324dc17a5963685e494 /gnu/packages/node.scm
parenta7a7186ce61d552ebbcb886f907a653cf67dc251 (diff)
downloadguix-patches-1fdb883082385ac8c9200b831630bea069f2945d.tar
guix-patches-1fdb883082385ac8c9200b831630bea069f2945d.tar.gz
gnu: node: Update to 7.10.0.
* gnu/packages/node.scm (node): Update to 7.10.0. (node)[arguments]: Disabled more tests. * gnu/packages/patches/node-9077.patch: Delete incompatible patch file. Recreate patch file from node pull request 9077. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index cb57415161..40c2b04ab3 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -38,14 +38,14 @@
(define-public node
(package
(name "node")
- (version "7.8.0")
+ (version "7.10.0")
(source (origin
(method url-fetch)
(uri (string-append "http://nodejs.org/dist/v" version
"/node-v" version ".tar.gz"))
(sha256
(base32
- "1nkngdjbsm81nn3v0w0c2aqx9nb7mwy3z49ynq4wwcrzfr9ap8ka"))
+ "00vdmb0z8b2sd547bkksgy9dfq5gi5xfd9b3f0rc4ngvpzl3z164"))
;; https://github.com/nodejs/node/pull/9077
(patches (search-patches "node-9077.patch"))))
(build-system gnu-build-system)
@@ -86,7 +86,9 @@
"test/parallel/test-cluster-master-error.js"
"test/parallel/test-cluster-master-kill.js"
"test/parallel/test-npm-install.js"
- "test/sequential/test-child-process-emfile.js"))
+ "test/sequential/test-child-process-emfile.js"
+ "test/sequential/test-benchmark-child-process.js"
+ "test/sequential/test-http-regr-gh-2928.js"))
#t))
(replace 'configure
;; Node's configure script is actually a python script, so we can't