summaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-08 03:42:19 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:16 +0100
commitfa9bc626c8ade896421aa137964c1ff987ed34af (patch)
treedda3e07600cd65b42e90b11730f4ccae551323b2 /gnu/packages/node-xyz.scm
parent161f2b1522cb5f16ed7d6574771d5edf1f12cc07 (diff)
downloadguix-patches-fa9bc626c8ade896421aa137964c1ff987ed34af.tar
guix-patches-fa9bc626c8ade896421aa137964c1ff987ed34af.tar.gz
gnu: Add node-serialport-binding-abstract.
* gnu/packages/node-xyz.scm (node-serialport-binding-abstract): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index f949aaa581..090468ab40 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -997,3 +997,37 @@ with a module name as argument provides a function that writes debug output to
@code{console.error} under that module name. This output can be controlled in
a more fine-grained manner by binding the @env{DEBUG} variable.")
(license license:expat)))
+
+(define-public node-serialport-binding-abstract
+ (package
+ (name "node-serialport-binding-abstract")
+ (version "9.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/serialport/node-serialport")
+ (commit "v9.2.7")))
+ (file-name (git-file-name "serialport-monorepo" version))
+ (sha256
+ (base32 "0x7zm59a5ff5yygjyw15xs3r5m3rb8av1yfrh4snn44mrwq87yg8"))))
+ (inputs
+ (list node-debug))
+ (build-system node-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda args
+ (chdir "packages/binding-abstract"))))
+ #:tests? #f))
+ (home-page "https://serialport.io")
+ (synopsis "Abstract base class for Node SerialPort bindings")
+ (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports. The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+This package provides the @code{AbstractBinding} class, the base for all Node
+SerialPort bindings. You wouldn't use this class directly, but instead extend
+it to make a new binding for a different platform or underling technology.")
+ (license license:expat)))