summaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-08 03:42:21 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:17 +0100
commitb5ffff233a2a73758f0febe0ff5d51f360b74f14 (patch)
tree836247a476940adb92b9df46071eefe001419eec /gnu/packages/node-xyz.scm
parente2dee179efe4d401191cff8e9eb541445c59120e (diff)
downloadguix-patches-b5ffff233a2a73758f0febe0ff5d51f360b74f14.tar
guix-patches-b5ffff233a2a73758f0febe0ff5d51f360b74f14.tar.gz
gnu: Add node-serialport-parser-readline.
* gnu/packages/node-xyz.scm (node-serialport-parser-readline): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index dbc2a40794..206f163bfc 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1053,3 +1053,26 @@ recommended high-level interface.
Parsers are used to take raw binary data and transform them into usable
messages. This package provides @code{Delimiter}, a parser that emits data
each time a specified byte sequence is received.")))
+
+(define-public node-serialport-parser-readline
+ (package
+ (inherit node-serialport-binding-abstract)
+ (name "node-serialport-parser-readline")
+ (version "9.2.4")
+ (inputs
+ (list node-serialport-parser-delimiter))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda args
+ (chdir "packages/parser-readline"))))
+ #:tests? #f))
+ (synopsis "Node SerialPort parser to split data on newlines")
+ (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports. The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+Parsers are used to take raw binary data and transform them into usable
+messages. This package provides @code{Readline}, a parser that emits data
+after a (configurable) newline delimiter is received.")))