summaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorRon Nazarov via Guix-patches via <guix-patches@gnu.org>2021-04-03 22:19:08 +0100
committerLeo Famulari <leo@famulari.name>2021-04-05 17:22:28 -0400
commitab0ed26eb70931e04c921ceef313ca67e3c6d61c (patch)
treeb3c31a2877e57744147bc057ee824dd2532119e7 /gnu/packages/node-xyz.scm
parent561017f83823253a496b1eb650377c96623c2385 (diff)
downloadguix-patches-ab0ed26eb70931e04c921ceef313ca67e3c6d61c.tar
guix-patches-ab0ed26eb70931e04c921ceef313ca67e3c6d61c.tar.gz
gnu: Add node-wrappy.
* gnu/packages/node-xyz.scm (node-wrappy): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 60cc005ea4..f401380310 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -272,3 +273,28 @@ function with browser support.")
"@code{node-semver} is a JavaScript implementation of the
@uref{https://semver.org/, SemVer.org} specification.")
(license license:isc)))
+
+(define-public node-wrappy
+ (package
+ (name "node-wrappy")
+ (version "1.0.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/npm/wrappy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ymlc61cja6v5438vwb04gq8wg2b784lj39zf0g4i36fvgcw9783"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f ; FIXME: Tests depend on node-tap
+ #:phases
+ (modify-phases %standard-phases
+ ;; The only dependency to check for is tap, which we don't have.
+ (delete 'configure))))
+ (home-page "https://github.com/npm/wrappy")
+ (synopsis "Callback wrapping utility")
+ (description "@code{wrappy} is a utility for Node.js to wrap callbacks.")
+ (license license:isc)))