summaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-07-20 11:34:19 +0200
committerMarius Bakke <marius@gnu.org>2022-07-20 16:50:08 +0200
commit9ae6dd7aa586ee702c7089e619376ca24920388e (patch)
treeddbc3a695f18302d612f17574e10122bc38de059 /gnu/packages/node-xyz.scm
parent13e50d75e879f06465a32edcab623ce1613a7436 (diff)
downloadguix-patches-9ae6dd7aa586ee702c7089e619376ca24920388e.tar
guix-patches-9ae6dd7aa586ee702c7089e619376ca24920388e.tar.gz
gnu: Add node-resolve-protobuf-schema.
* gnu/packages/node-xyz.scm (node-resolve-protobuf-schema): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 97ed294721..4ed1334abc 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -257,6 +257,35 @@ while being as light-weight and simple as possible.")
written in Javascript.")
(license license:expat)))
+(define-public node-resolve-protobuf-schema
+ (package
+ (name "node-resolve-protobuf-schema")
+ (version "2.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mafintosh/resolve-protobuf-schema")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zxavr0b2yz9xzp6zlsg5g09i0a6zqb24j12rdvfgph6wd4mzk40"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "npm" "--offline" "--ignore-scripts" "install"
+ "--production"))))))
+ (inputs (list node-protocol-buffers-schema))
+ (home-page "https://github.com/mafintosh/resolve-protobuf-schema")
+ (synopsis "Resolve protobuf imports")
+ (description
+ "This package can read a protobuf schema from the disk, parse it and
+resolve all imports.")
+ (license license:expat)))
+
(define-public node-stack-trace
;; There have been improvements since the last release.
(let ((commit "4fd379ee78965ce7ce8820b436f1b1b590d5dbcf")