summaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-08 03:42:27 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:18 +0100
commit8ff1e9adc22bc126814014947d286208b57ba29c (patch)
tree40c08292be383f1fe501b749786615fa7f95fd7f /gnu/packages/node-xyz.scm
parent5a621e83d854494630b61f9720e28a4aebf9c1df (diff)
downloadguix-patches-8ff1e9adc22bc126814014947d286208b57ba29c.tar
guix-patches-8ff1e9adc22bc126814014947d286208b57ba29c.tar.gz
gnu: Add node-serialport-parser-byte-length.
* gnu/packages/node-xyz.scm (node-serialport-parser-byte-length): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 1f2934432b..d5b2ed3a44 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -1220,3 +1220,25 @@ Parsers are used to take raw binary data and transform them into usable
messages. This package provides @code{CCTalk}, which emits packets for the
ccTalk protocol (an open standard for currency detectors) as they are
received.")))
+
+(define-public node-serialport-parser-byte-length
+ (package
+ (inherit node-serialport-binding-abstract)
+ (name "node-serialport-parser-byte-length")
+ (version "9.2.4")
+ (inputs `())
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda args
+ (chdir "packages/parser-byte-length"))))
+ #:tests? #f))
+ (synopsis "Node SerialPort parser for fixed-length buffers")
+ (description "Node SerialPort is a modular suite of Node.js packages for
+accessing serial ports. The Guix package @code{node-serialport} provides the
+recommended high-level interface.
+
+Parsers are used to take raw binary data and transform them into usable
+messages. This package provides @code{ByteLength}, a parser that emits data
+as a buffer every time a specified number of bytes are received.")))