summaryrefslogtreecommitdiff
path: root/gnu/packages/nim.scm
diff options
context:
space:
mode:
authorJosé Miguel Sánchez García <jmi2k@openmailbox.org>2017-01-09 18:15:37 +0100
committerDavid Craven <david@craven.ch>2017-01-09 18:01:52 +0100
commit84aafbbb664925ed1a9de3e53238bc54c743a968 (patch)
treeeffd8b7d0331f550440b32804af0630fa1221e9c /gnu/packages/nim.scm
parent5d18d776d269ab9a6c44e049936389df3454ba30 (diff)
downloadguix-patches-84aafbbb664925ed1a9de3e53238bc54c743a968.tar
guix-patches-84aafbbb664925ed1a9de3e53238bc54c743a968.tar.gz
gnu: Add nim.
* gnu/packages/nim.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add nim.scm.
Diffstat (limited to 'gnu/packages/nim.scm')
-rw-r--r--gnu/packages/nim.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/nim.scm b/gnu/packages/nim.scm
new file mode 100644
index 0000000000..c249e2be93
--- /dev/null
+++ b/gnu/packages/nim.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages nim)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+(define-public nim
+ (package
+ (name "nim")
+ (version "0.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://nim-lang.org/download/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0rsibhkc5n548bn9yyb9ycrdgaph5kq84sfxc9gabjs7pqirh6cy"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No tests.
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'patch-installer
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "install.sh"
+ (("1/nim") "1"))
+ #t)))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* "./install.sh" out))))))))
+ (home-page "http://nim-lang.org")
+ (synopsis "Statically-typed, imperative programming language")
+ (description "Nim (formerly known as Nimrod) is a statically-typed,
+imperative programming language that tries to give the programmer ultimate power
+without compromises on runtime efficiency. This means it focuses on compile-time
+mechanisms in all their various forms.")
+ (license license:expat)))