summaryrefslogtreecommitdiff
path: root/gnu/packages/nim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-07 13:36:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-07 13:37:28 +0300
commit6eed26443f04b872a2738caca4c762718da6dfd7 (patch)
tree8c1a348e0d4d295fea97257c0421c1f19762ecd4 /gnu/packages/nim.scm
parent83fef82b7c0f9b8c57e072281ef9d4518d854350 (diff)
downloadguix-patches-6eed26443f04b872a2738caca4c762718da6dfd7.tar
guix-patches-6eed26443f04b872a2738caca4c762718da6dfd7.tar.gz
gnu: nim: Update to 0.17.0.
* gnu/packages/nim.scm (nim): Update to 0.17.0. [source, home-page]: Use https. [arguments]: Patch more shebangs, use custom build phase.
Diffstat (limited to 'gnu/packages/nim.scm')
-rw-r--r--gnu/packages/nim.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/nim.scm b/gnu/packages/nim.scm
index c249e2be93..560f10e4ad 100644
--- a/gnu/packages/nim.scm
+++ b/gnu/packages/nim.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.org>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,15 +26,15 @@
(define-public nim
(package
(name "nim")
- (version "0.16.0")
+ (version "0.17.0")
(source
(origin
(method url-fetch)
- (uri (string-append "http://nim-lang.org/download/"
+ (uri (string-append "https://nim-lang.org/download/"
name "-" version ".tar.xz"))
(sha256
(base32
- "0rsibhkc5n548bn9yyb9ycrdgaph5kq84sfxc9gabjs7pqirh6cy"))))
+ "16vsmk4rqnkg9lc9h9jk62ps0x778cdqg6qrs3k6fv2g73cqvq9n"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; No tests.
@@ -46,11 +47,21 @@
(substitute* "install.sh"
(("1/nim") "1"))
#t)))
+ (add-after 'patch-source-shebangs 'patch-more-shebangs
+ (lambda _
+ (substitute* (append '("tests/stdlib/tosprocterminate.nim"
+ "lib/pure/osproc.nim")
+ (find-files "c_code" "stdlib_osproc.c"))
+ (("/bin/sh") (which "sh")))
+ #t))
+ (replace 'build
+ (lambda _
+ (zero? (system* "sh" "build.sh"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(zero? (system* "./install.sh" out))))))))
- (home-page "http://nim-lang.org")
+ (home-page "https://nim-lang.org")
(synopsis "Statically-typed, imperative programming language")
(description "Nim (formerly known as Nimrod) is a statically-typed,
imperative programming language that tries to give the programmer ultimate power