summaryrefslogtreecommitdiff
path: root/gnu/packages/nim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-03 18:22:21 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-03 20:01:24 +0300
commit68b6eaf1d9b05c87c6d8abbe8c4d0b45d9b723ac (patch)
treed82250545972141d752bd57d43c2df9354be02f6 /gnu/packages/nim.scm
parentd50f8b7ddc913a0d89af891846564777bdf1bc9c (diff)
downloadguix-patches-68b6eaf1d9b05c87c6d8abbe8c4d0b45d9b723ac.tar
guix-patches-68b6eaf1d9b05c87c6d8abbe8c4d0b45d9b723ac.tar.gz
gnu: nim: Prepare for running tests.
* gnu/packages/nim.scm (nim)[arguments]: Replace default 'check phase. [native-inputs]: Add nss-certs.
Diffstat (limited to 'gnu/packages/nim.scm')
-rw-r--r--gnu/packages/nim.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/nim.scm b/gnu/packages/nim.scm
index cf6d19c518..179a6ea0e3 100644
--- a/gnu/packages/nim.scm
+++ b/gnu/packages/nim.scm
@@ -25,7 +25,8 @@
#:use-module (guix build-system gnu)
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages))
+ #:use-module (guix packages)
+ #:use-module (gnu packages certs))
(define-public nim
(package
@@ -70,6 +71,10 @@
(invoke "./bin/nim" "c" "-d:release" "koch")
(invoke "./koch" "boot" "-d:release")
(invoke "./koch" "tools")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./koch" "tests"))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out") "/bin")))
@@ -93,6 +98,7 @@
(string-append zsh "/_nim"))
(copy-file "dist/nimble/nimble.bash-completion"
(string-append zsh "/_nimble"))))))))
+ (native-inputs (list nss-certs))
(home-page "https://nim-lang.org")
(synopsis "Statically-typed, imperative programming language")
(description "Nim (formerly known as Nimrod) is a statically-typed,