summaryrefslogtreecommitdiff
path: root/gnu/packages/nickle.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-19 18:10:15 +0000
committerLeo Famulari <leo@famulari.name>2016-09-23 18:54:24 -0400
commit0f5de84e983bdb65db261ecf5963d4208a8474e4 (patch)
treee1c535d06d5780ba5fb0a5e1061993e22380a129 /gnu/packages/nickle.scm
parent047cd01d11539b4afc547e430ae7f3b9af976bea (diff)
downloadguix-patches-0f5de84e983bdb65db261ecf5963d4208a8474e4.tar
guix-patches-0f5de84e983bdb65db261ecf5963d4208a8474e4.tar.gz
gnu: Add nickle.
* gnu/packages/nickle.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/nickle.scm')
-rw-r--r--gnu/packages/nickle.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/nickle.scm b/gnu/packages/nickle.scm
new file mode 100644
index 0000000000..1312aecbbd
--- /dev/null
+++ b/gnu/packages/nickle.scm
@@ -0,0 +1,54 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 ng0 <ngillmann@runbox.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages nickle)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages readline)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+(define-public nickle
+ (package
+ (name "nickle")
+ (version "2.77")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://nickle.org/release/nickle-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0rhij7cn1zkn8wzxyjkamz9fs262zyg80p6v6i864hdalg4plpm3"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("readline" ,readline)))
+ (synopsis "Numeric oriented programming language")
+ (description
+ "Nickle is a programming language based prototyping environment with
+powerful programming and scripting capabilities. Nickle supports a variety of
+datatypes, especially arbitrary precision numbers. The programming language
+vaguely resembles C. Some things in C which do not translate easily are
+different, some design choices have been made differently, and a very few
+features are simply missing. Nickle provides the functionality of Unix bc, dc
+and expr in a different form. It is also an ideal environment for prototyping
+complex algorithms. Nickle's scripting capabilities make it a replacement for
+spreadsheets in some applications, and its numeric features complement the
+limited numeric functionality of text-oriented languages such as AWK and Perl.")
+ (home-page "https://nickle.org/")
+ (license license:expat)))