summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-02-25 16:02:10 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-20 17:47:03 +0100
commitf5e69549ba5d6efcd03f4f50f771a8a76ed73c5b (patch)
treef427b9998c0e0b6dbf6166b3b746d269dfc68f04 /gnu/packages/networking.scm
parent5adfaa6853213c7125f1dcac378b7c8f77c97ef3 (diff)
downloadguix-patches-f5e69549ba5d6efcd03f4f50f771a8a76ed73c5b.tar
guix-patches-f5e69549ba5d6efcd03f4f50f771a8a76ed73c5b.tar.gz
gnu: Add usrsctp.
* gnu/packages/networking.scm (usrsctp): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index e95e4870e9..3f6023c966 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -142,6 +142,35 @@
#:use-module (gnu packages xml)
#:use-module (ice-9 match))
+(define-public usrsctp
+ (package
+ (name "usrsctp")
+ (version "0.9.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/sctplab/usrsctp")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10ndzkip8blgkw572n3dicl6mgjaa7kygwn3vls80liq92vf1sa9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)
+ ("which" ,which)))
+ (home-page "https://github.com/sctplab/usrsctp/")
+ (synopsis "SCTP user-land implementation")
+ (description "UsrSCTP is a portable SCTP userland stack. SCTP is a message
+oriented, reliable transport protocol with direct support for multihoming that
+runs on top of IP or UDP, and supports both v4 and v6 versions.")
+ (license license:bsd-3)))
+
(define-public axel
(package
(name "axel")