summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2022-05-17 20:46:53 +0100
committerPierre Langlois <pierre.langlois@gmx.com>2022-05-30 22:18:21 +0100
commitb8fc3403d3c09c00a4b0ab68c9f4f296928479b9 (patch)
treefa178c12fd3d146d3c3dfc1cfcee18c86fd6b078 /gnu/packages/networking.scm
parentf12d08c6d2a306d1e103af44e2260b8aa7f1d91d (diff)
downloadguix-patches-b8fc3403d3c09c00a4b0ab68c9f4f296928479b9.tar
guix-patches-b8fc3403d3c09c00a4b0ab68c9f4f296928479b9.tar.gz
gnu: gandi.cli: Fix by downgrading python-click.
* gnu/packages/python-xyz.scm (python-click-7): New variable. * gnu/packages/networking.scm (gandi.cli)[inputs]: Depend on python-click-7.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 99145b2b47..2d1cb50f4a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Simon South <simon@simonsouth.net>
+;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1655,7 +1656,7 @@ round-robin fashion.")
(propagated-inputs
(list openssh)) ; used by gandi/cli/modules/iass.py
(inputs
- (list openssl python-click python-ipy python-pyyaml python-requests))
+ (list openssl python-click-7 python-ipy python-pyyaml python-requests))
(home-page "https://cli.gandi.net")
(synopsis "Command-line interface to the Gandi.net Web API")
(description