summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorDiego Nicola Barbato <dnbarbato@posteo.de>2019-12-04 17:02:04 +0100
committerLudovic Courtès <ludo@gnu.org>2019-12-11 12:13:03 +0100
commita0993c29da668f85ba16b209c4c064c3af4e6bd3 (patch)
treeb05f0e334e140537f294ce0e6ce659c462b3fc90 /gnu/packages/networking.scm
parent263a267b75e472cb84428571580dabd99d5dff0c (diff)
downloadguix-patches-a0993c29da668f85ba16b209c4c064c3af4e6bd3.tar
guix-patches-a0993c29da668f85ba16b209c4c064c3af4e6bd3.tar.gz
gnu: Add vde2.
* gnu/packages/networking.scm (vde2): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3ddf5975d7..e4190e98d4 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;; Copyright © 2019 Daniel Schaefer <git@danielschaefer.me>
+;;; Copyright © 2019 Diego N. Barbato <dnbarbato@posteo.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2822,3 +2823,33 @@ to be a teaching tool and presents the subnetting results as
easy-to-understand binary values.")
(home-page "http://jodies.de/ipcalc")
(license license:gpl2+)))
+
+(define-public vde2
+ (package
+ (name "vde2")
+ (version "2.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri "mirror://sourceforge/vde/vde2/2.3.2/vde2-2.3.2.tar.gz")
+ (sha256
+ (base32 "14xga0ib6p1wrv3hkl4sa89yzjxv7f1vfqaxsch87j6scdm59pr2"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:parallel-build? #f)) ; Build fails if #t.
+ (inputs
+ `(("python" ,python)
+ ("libpcap" ,libpcap)
+ ("openssl" ,openssl-1.0))) ; Build fails with 1.1.
+ (home-page "https://github.com/virtualsquare/vde-2")
+ (synopsis "Virtual Distributed Ethernet")
+ (description "VDE is a set of programs to provide virtual software-defined
+Ethernet network interface controllers across multiple virtual or
+physical, local or remote devices. The VDE architecture provides
+virtual counterparts to hardware components such as switches and
+cables.")
+ (license (list license:gpl2
+ license:lgpl2.1 ; libvdeplug
+ (license:non-copyleft ; slirpvde
+ "file://COPYING.slirpvde"
+ "See COPYING.slirpvde in the distribution.")))))