summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorAlex Griffin <a@ajgrf.com>2019-11-26 13:43:15 -0600
committerAlex Griffin <a@ajgrf.com>2019-12-02 09:45:32 -0600
commit8c655deb7d925e1179498066bdffcad8d45af0cf (patch)
tree29687a6884795f8615b8d441ca39ac4b533efce6 /gnu/packages/networking.scm
parentd97cdff18ece9ce3a6caa39e8779d597f535e082 (diff)
downloadguix-patches-8c655deb7d925e1179498066bdffcad8d45af0cf.tar
guix-patches-8c655deb7d925e1179498066bdffcad8d45af0cf.tar.gz
gnu: pagekite: Update to 1.5.0.191126.
* gnu/packages/networking.scm (pagekite): Update to 1.5.0.191126. [source]: Fetch from GitHub. [arguments]: Build with Python 3. [inputs]: Add python-six.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f689ef1b75..45e3a34369 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2745,21 +2745,19 @@ module @code{batman-adv}, for Layer 2.")
(define-public pagekite
(package
(name "pagekite")
- (version "1.0.0.190721")
+ (version "1.5.0.191126")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://pagekite.net/pk/src/pagekite-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pagekite/PyPagekite.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0y4vaqd3pjr6if8jcnhjwignkxgrajmnx1rd1p37anj8xjg7l8zh"))))
+ (base32 "0mncfjfrr13sm84g5z49qxg5cy791h5qxphjsl77x91zs3m36c8l"))))
(build-system python-build-system)
(arguments
- ;; Python 3 support is a work-in-progress and should come soon:
- ;; https://github.com/pagekite/PyPagekite/issues/40
- ;; https://github.com/pagekite/PyPagekite/pull/71
- `(#:python ,python-2
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'install 'install-man-page
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -2771,7 +2769,8 @@ module @code{batman-adv}, for Layer 2.")
(install-file "doc/pagekite.1" (string-append man "/man1"))
#t))))))
(inputs
- `(("python2-socksipychain" ,python2-socksipychain)))
+ `(("python-six" ,python-six)
+ ("python-socksipychain" ,python-socksipychain)))
(home-page "https://pagekite.net/")
(synopsis "Make localhost servers publicly visible")
(description