summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2016-07-28 23:38:19 +0200
committerLeo Famulari <leo@famulari.name>2016-08-08 22:36:36 -0400
commit87b14091409f2d2ea7bec39edb6e727d6df909a3 (patch)
treea71804ea0929316399e6c11bb52b6a85c84cdc82 /gnu/packages/networking.scm
parent68b14f2e157dc3fd78b3b91a95d0491020462d35 (diff)
downloadguix-patches-87b14091409f2d2ea7bec39edb6e727d6df909a3.tar
guix-patches-87b14091409f2d2ea7bec39edb6e727d6df909a3.tar.gz
gnu: Add perl-socket6.
* gnu/packages/networking.scm (perl-socket6): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index e146f8b902..98ac87a54e 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -436,3 +436,36 @@ application stack itself.")
"Perl Interface to the Domain Name System")
(description "Net::DNS is the Perl Interface to the Domain Name System.")
(license license:x11)))
+
+(define-public perl-socket6
+ (package
+ (name "perl-socket6")
+ (version "0.28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/U/UM/UMEMOTO/Socket6-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "11j5jzqbzmwlws9zals43ry2f1nw9qy6im7yhn9ck5rikywrmm5z"))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (args `("Makefile.PL"
+ ,(string-append "PREFIX=" out)
+ "INSTALLDIRS=site")))
+ (setenv "CONFIG_SHELL" (which "sh"))
+ (zero? (apply system* "perl" args))))))))
+ (home-page "http://search.cpan.org/dist/Socket6")
+ (synopsis
+ "IPv6 related part of the C socket.h defines and structure manipulators for Perl")
+ (description "Socket6 binds the IPv6 related part of the C socket header
+definitions and structure manipulators for Perl.")
+ (license license:bsd-3)))