summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-18 19:04:19 +0200
committerMarius Bakke <marius@gnu.org>2021-05-18 22:23:48 +0200
commit72c0b147ffde3cd0ea26907ee2bca5655d12b6f0 (patch)
tree05809f141f7aa79fa0323adb1f7c4ee8db3de7fd /gnu/packages/networking.scm
parentdef0b7fcaca586227bdcf318966ce3080074dc79 (diff)
downloadguix-patches-72c0b147ffde3cd0ea26907ee2bca5655d12b6f0.tar
guix-patches-72c0b147ffde3cd0ea26907ee2bca5655d12b6f0.tar.gz
gnu: iwd: Update to 1.14.
* gnu/packages/networking.scm (iwd): Update to 1.14. [source]: Switch to URL-FETCH. [native-inputs]: Remove ASCIIDOC, AUTOCONF, AUTOMAKE and LIBTOOL. Add PYTHON-DOCUTILS. [arguments]: Remove obsolete configure flag. Don't disable test, adjust Makefile substitution to work with bootstrapped sources.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm35
1 files changed, 14 insertions, 21 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 561b295b1e..6292241007 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2018 Tonton <tonton@riseup.net>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Theodoros Foradis <theodoros@foradis.org>
-;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -3599,28 +3599,26 @@ protocol daemons for BGP, IS-IS, LDP, OSPF, PIM, and RIP. ")
(define-public iwd
(package
(name "iwd")
- (version "0.21")
+ (version "1.14")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.kernel.org/pub/scm/network/wireless/iwd.git")
- (commit version)))
- (file-name (git-file-name name version))
+ ;; FIXME: We're using the bootstrapped sources because
+ ;; otherwise using an external ell library is impossible.
+ ;; How to bootstrap with Guix?
+ (method url-fetch)
+ (uri (string-append "https://www.kernel.org/pub/linux/network"
+ "/wireless/iwd-" version ".tar.xz"))
(sha256
(base32
- "001dikinsa6kshwscjbvwipavzwpqnpvx9fpshcn63gbvbhyd393"))))
+ "02vz4lyd6vq3vcii357ljqprnas78zb8j670a0gblrm6kganmgi1"))))
(build-system gnu-build-system)
(inputs
`(("dbus" ,dbus)
("ell" ,ell)
("readline" ,readline)))
(native-inputs
- `(("asciidoc" ,asciidoc)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkgconfig" ,pkg-config)
+ `(("pkgconfig" ,pkg-config)
("python" ,python)
+ ("rst2man" ,python-docutils)
("openssl" ,openssl)))
(arguments
`(#:configure-flags
@@ -3630,22 +3628,17 @@ protocol daemons for BGP, IS-IS, LDP, OSPF, PIM, and RIP. ")
"--enable-hwsim"
"--enable-tools"
"--enable-wired"
- "--enable-docs"
"--localstatedir=/var"
(string-append "--with-dbus-datadir=" dbus "/share/")
(string-append "--with-dbus-busdir="
dbus "/share/dbus-1/system-services")))
#:phases
(modify-phases %standard-phases
- (add-before 'bootstrap 'pre-bootstrap
+ (add-after 'configure 'patch-Makefile
(lambda _
- (substitute* "Makefile.am"
- ;; Test disabled because it needs the kernel module
- ;; 'pkcs8_key_parser' loaded.
- (("unit\\/test-eapol.*? ") "")
+ (substitute* "Makefile"
;; Don't try to 'mkdir /var'.
- (("\\$\\(MKDIR_P\\) -m 700") "true"))
- #t)))))
+ (("\\$\\(MKDIR_P\\) -m 700") "true")))))))
(home-page "https://git.kernel.org/pub/scm/network/wireless/iwd.git/")
(synopsis "Internet Wireless Daemon")
(description "iwd is a wireless daemon for Linux that aims to replace WPA