summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-12-28 17:53:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-12-28 19:04:34 +0200
commit646233094e4b6361626e59ff582017724a31e86a (patch)
tree3ce5919fa30df55b5b6b842212a2a70afccde7c4 /gnu/packages/networking.scm
parentd482569c2289647e666228cad238552b18f09410 (diff)
downloadguix-patches-646233094e4b6361626e59ff582017724a31e86a.tar
guix-patches-646233094e4b6361626e59ff582017724a31e86a.tar.gz
gnu: whois: Fetch from upstream repository.
* gnu/packages/networking.scm (whois)[source]: Download from upstream git repository.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index f2ec4d792f..796c42b0ee 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1307,11 +1307,13 @@ and up to 1 Mbit/s downstream.")
(version "5.5.7")
(source
(origin
- (method url-fetch)
- (uri (string-append "mirror://debian/pool/main/w/whois/"
- "whois_" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rfc1036/whois")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "14vkf7vkvlfwq45fcsq5dbwnjnkfrmv33br13g1jgl9qpw6p1yiy"))))
+ (base32 "1w3d0ffl0ng1m4i10k968kk4xicviq24w5vwl6d8dhja61d7yd2r"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no test suite