summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-19 00:04:32 +0100
committerMarius Bakke <marius@gnu.org>2020-11-19 00:04:32 +0100
commit35ed83beae51c05069ed6754dd26cf0f549808ab (patch)
treefe09aa72524081aa54c74e6d5f99f1a1c006c06b /gnu/packages/networking.scm
parent38f4c54d7e212fd26e6899fad29c2e604abb32f5 (diff)
parent0305bc91762f9d5e01abd3d55e8dd9d3d1ecbdad (diff)
downloadguix-patches-35ed83beae51c05069ed6754dd26cf0f549808ab.tar
guix-patches-35ed83beae51c05069ed6754dd26cf0f549808ab.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm32
1 files changed, 30 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 51404a52af..8f76ab9d91 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -141,6 +141,34 @@
#:use-module (gnu packages xml)
#:use-module (ice-9 match))
+(define-public axel
+ (package
+ (name "axel")
+ (version "2.17.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/axel-download-accelerator/axel/"
+ "releases/download/v" version "/"
+ "axel-" version ".tar.xz"))
+ (sha256
+ (base32 "0m1smb9rmw9w2fcfcf0162qyffx6a1x0j612sg3fydflandlsdpi"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libressl" ,libressl)))
+ (home-page "https://github.com/axel-download-accelerator/axel")
+ (synopsis "Light command line download accelerator")
+ (description
+ "Axel tries to accelerate the download process by using multiple
+connections per file, and can also balance the load between different
+servers. It tries to be as light as possible, so it might be useful
+on byte-critical systems. It supports HTTP, HTTPS, FTP and FTPS
+protocols.")
+ (license license:gpl2+)))
+
;; This package does not have a release yet.
;; But this is required to provide a feature in PipeWire.
(define-public libcamera
@@ -2142,14 +2170,14 @@ HTTP proxies.")
(define-public enet
(package
(name "enet")
- (version "1.3.16")
+ (version "1.3.17")
(source
(origin
(method url-fetch)
(uri (string-append "http://enet.bespin.org/download/"
"enet-" version ".tar.gz"))
(sha256
- (base32 "1lggc82rbzscci057dqqyhkbq4j6mr5k01hbrvn06jkzc2xpxdxv"))))
+ (base32 "1p6f9mby86af6cs7pv6h48032ip9g32c05cb7d9mimam8lchz3x3"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))