summaryrefslogtreecommitdiff
path: root/gnu/packages/nettle.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-09 18:32:32 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-09 18:49:28 +0200
commit0be199c976332fd655c547bb122d1214cc9bc452 (patch)
treefddad6dd69fe317795ea3d9c606d051d806fe33e /gnu/packages/nettle.scm
parent1421afa94a825d413a5609ef0d89b878e1ba458c (diff)
downloadguix-patches-0be199c976332fd655c547bb122d1214cc9bc452.tar
guix-patches-0be199c976332fd655c547bb122d1214cc9bc452.tar.gz
gnu: nettle: Make version 3 the default.
* gnu/packages/nettle.scm (nettle): Rename to... (nettle-2): ... this. (nettle-3): Rename to... (nettle): ... this. * gnu/packages/gnutls.scm (gnutls): Use NETTLE-2. * gnu/packages/lsh.scm (lsh): Likewise.
Diffstat (limited to 'gnu/packages/nettle.scm')
-rw-r--r--gnu/packages/nettle.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/nettle.scm b/gnu/packages/nettle.scm
index 0df8f001bf..ae432c7bc7 100644
--- a/gnu/packages/nettle.scm
+++ b/gnu/packages/nettle.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,7 +24,7 @@
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages m4))
-(define-public nettle
+(define-public nettle-2
(package
(name "nettle")
(version "2.7.1")
@@ -53,10 +53,10 @@ cryptographic toolkits for object-oriented languages or in applications
themselves.")
(license gpl2+)))
-(define-public nettle-3
+(define-public nettle
;; This version is not API-compatible with version 2. In particular GnuTLS
;; cannot use it yet. So keep it separate.
- (package (inherit nettle)
+ (package (inherit nettle-2)
(version "3.0")
(source (origin
(method url-fetch)