summaryrefslogtreecommitdiff
path: root/gnu/packages/netpbm.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-03-30 18:09:10 -0500
committerEric Bavier <bavier@member.fsf.org>2014-03-31 10:34:17 -0500
commitd4bf49b140bd5cfb3580d2a038679160dc1331b5 (patch)
tree97dea95df158a4c79546d3f18f07407ed16813e8 /gnu/packages/netpbm.scm
parent36b5851df6d0833a7cf64673a65564afa5dd5ccc (diff)
downloadguix-patches-d4bf49b140bd5cfb3580d2a038679160dc1331b5.tar
guix-patches-d4bf49b140bd5cfb3580d2a038679160dc1331b5.tar.gz
gnu: Remove unused lambda arguments and prefer separate phases over
augmented phases. * gnu/packages/compression.scm (sharutils) [arguments]: Remove unused lambda args. * gnu/packages/gl.scm (mesa) [arguments]: Same * gnu/packages/fltk.scm [arguments]: Same. Substitute const check phase with #:tests? #f. Add pre-configure phase. * gnu/packages/ghostscript.scm (ghostscript) [arguments]: Put makefile patches in separate phase. Put so steps oinseparate phases. * gnu/packages/glib.scm (gobject-introspection) [arguments]: Remove unused lambda args. Put patches in pre-configure phase. * gnu/packages/gnupg.scm (gnupg) [arguments]: Put patch in pre-configure phase. (pius) [arguments]: Delete const #t configure and build phases. (signing-party) [arguments]: Factor patches into post-unpack phase. (paperkey) [arguments]: Remove unused lambda args. Factor out patches into pre-check phase. * gnu/packages/icu4c.scm [arguments]: Change source dir after standard unpack phase. Factor configure patches into pre-configure phase. * gnu/packages/lsof.scm [arguments]: Remove unused lambda args. Remove unnecessary apply. * gnu/packages/lvm.scm (lvm2) [arguments]: Factor out patches into pre-configure phase. * gnu/packages/libtiff.scm [arguments]: Same * gnu/packages/maths.scm (hdf5) [arguments]: Same * gnu/packages/gtk.scm (gtk+-2) [arguments]: Same * gnu/packages/mp3.scm (libmad) [arguments]: Same (id3lib) [arguments]: Same * gnu/packages/python.scm (python-2) [arguments]: Same * gnu/packages/texlive.scm (texlive) [arguments]: Same * gnu/packages/pretty-print.scm (a2ps) [arguments]: Same (trueprint) [arguments]: Same (source-highlight) [arguments]: Same. Remove unused lambda args. * gnu/packages/netpbm.scm [arguments]: Remove unused lambda args. Factor out test patches into pre-check phase. Condense calls to substitute* * gnu/packages/openldap.scm [arguments]: Factor out libtool copy into post-configure phases. [synopsis] Remove package name. * gnu/packages/ssh.scm (openssh) [arguments]: Factor out patches into separate phases. * gnu/packages/tcsh.scm [arguments]: Factor out test patches into pre-check phase. * gnu/packages/version-control.scm (git) [arguments]: Factor out patches into post-configure phase. * gnu/packages/vim.scm [arguments]: Same. [synopsis] Remove package name. * gnu/packages/vpn.scm (openconnect) [arguments]: Put configure flags in #:configure-flags
Diffstat (limited to 'gnu/packages/netpbm.scm')
-rw-r--r--gnu/packages/netpbm.scm47
1 files changed, 23 insertions, 24 deletions
diff --git a/gnu/packages/netpbm.scm b/gnu/packages/netpbm.scm
index 01d672e01d..64db777c71 100644
--- a/gnu/packages/netpbm.scm
+++ b/gnu/packages/netpbm.scm
@@ -64,7 +64,7 @@
`(#:phases
(alist-replace
'configure
- (lambda* (#:key #:allow-other-keys #:rest args)
+ (lambda _
(copy-file "config.mk.in" "config.mk")
(let ((f (open-file "config.mk" "a")))
(display "CC=gcc\n" f)
@@ -77,30 +77,29 @@
(substitute* "converter/ppm/Makefile" (("hpcdtoppm") ""))
;; drop programs without license, see
;; http://packages.debian.org/changelogs/pool/main/n/netpbm-free/netpbm-free_10.0-12.2/libnetpbm10.copyright
- (substitute* "converter/pbm/Makefile" (("pbmto4425") ""))
- (substitute* "converter/pbm/Makefile" (("pbmtoln03") ""))
- (substitute* "converter/pbm/Makefile" (("pbmtolps") ""))
- (substitute* "converter/pbm/Makefile" (("pbmtopk") ""))
- (substitute* "converter/pbm/Makefile" (("pktopbm") ""))
+ (substitute* "converter/pbm/Makefile"
+ (("pbmto4425") "")
+ (("pbmtoln03") "")
+ (("pbmtolps") "")
+ (("pbmtopk") "")
+ (("pktopbm") ""))
(substitute* "converter/pgm/Makefile" (("spottopgm") ""))
- (substitute* "converter/ppm/Makefile" (("ppmtopjxl") ""))
- ))
- (alist-replace
- 'check
- (lambda* (#:key #:allow-other-keys #:rest args)
- (let ((check (assoc-ref %standard-phases 'check)))
- ;; install temporarily into /tmp/netpbm
- (system* "make" "package")
- ;; remove test requiring X
- (substitute* "test/all-in-place.test" (("pamx") ""))
- ;; do not worry about non-existing file
- (substitute* "test/all-in-place.test" (("^rm ") "rm -f "))
- ;; remove four tests that fail for unknown reasons
- (substitute* "test/Test-Order" (("all-in-place.test") ""))
- (substitute* "test/Test-Order" (("pnmpsnr.test") ""))
- (substitute* "test/Test-Order" (("pnmremap1.test") ""))
- (substitute* "test/Test-Order" (("gif-roundtrip.test") ""))
- (apply check args)))
+ (substitute* "converter/ppm/Makefile" (("ppmtopjxl") ""))))
+ (alist-cons-before
+ 'check 'setup-check
+ (lambda _
+ ;; install temporarily into /tmp/netpbm
+ (system* "make" "package")
+ ;; remove test requiring X
+ (substitute* "test/all-in-place.test" (("pamx") ""))
+ ;; do not worry about non-existing file
+ (substitute* "test/all-in-place.test" (("^rm ") "rm -f "))
+ ;; remove four tests that fail for unknown reasons
+ (substitute* "test/Test-Order"
+ (("all-in-place.test") "")
+ (("pnmpsnr.test") "")
+ (("pnmremap1.test") "")
+ (("gif-roundtrip.test") "")))
(alist-replace
'install
(lambda* (#:key outputs make-flags #:allow-other-keys)