summaryrefslogtreecommitdiff
path: root/gnu/packages/netpbm.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-01-23 23:27:20 +0100
committerAndreas Enge <andreas@enge.fr>2015-01-23 23:27:20 +0100
commit7d8379a7679658acf9c15c4788881674d80a2488 (patch)
treed5776ad411d6e15462b64373f4d85c79af9dbcc2 /gnu/packages/netpbm.scm
parente066928977bf047bdb06386890b13971ac9c8154 (diff)
downloadguix-patches-7d8379a7679658acf9c15c4788881674d80a2488.tar
guix-patches-7d8379a7679658acf9c15c4788881674d80a2488.tar.gz
gnu: netpbm: Switch to svn checkout.
* gnu/packages/netpbm.scm (netpbm): Use svn-fetch for the source instead of a separately hosted tarball.
Diffstat (limited to 'gnu/packages/netpbm.scm')
-rw-r--r--gnu/packages/netpbm.scm31
1 files changed, 18 insertions, 13 deletions
diff --git a/gnu/packages/netpbm.scm b/gnu/packages/netpbm.scm
index 0fdcf4ceae..e72cf32e3f 100644
--- a/gnu/packages/netpbm.scm
+++ b/gnu/packages/netpbm.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,26 +26,30 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages xml)
+ #:use-module (guix build-system gnu)
#:use-module ((guix licenses) #:select (gpl2))
#:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
+ #:use-module (guix svn-download))
(define-public netpbm
(package
(name "netpbm")
(version "10.61.01")
(source (origin
- (method url-fetch)
- ;; The "super-stable" and "stable" versions do not compile
- ;; with newer libpng; we need the "advanced" version. The tarball
- ;; on the server is generated by sourceforge from the "advanced"
- ;; branch of the subversion repository:
- ;; svn checkout http://netpbm.svn.sourceforge.net/svnroot/netpbm/advanced netpbm-version
- (uri (string-append "http://www.multiprecision.org/guix/netpbm-"
- version ".tar.xz"))
- (sha256 (base32
- "10nwvxc85kr6vhlhhahagy7s9848bbixl54b0p4ppim4g0dl10jz"))))
+ (method svn-fetch)
+ ;; At the time of first packaging, the "super-stable" and
+ ;; "stable" versions did not compile with newer libpng;
+ ;; we needed the "advanced" version.
+ ;; The currently highest stable version is 10.47.53,
+ ;; the currently highest advanced version is 10.69.4,
+ ;; svn release 2397.
+ ;; To determine the correct release: "svn log version.mk".
+ (uri (svn-reference
+ (url "http://svn.code.sf.net/p/netpbm/code/advanced")
+ (revision 1832)))
+ (sha256
+ (base32
+ "1mj1pqq18yj0yb6l24zfjls7axhqmiv0pvcaabl5xvc4a0dm543j"))))
(build-system gnu-build-system)
(inputs `(("ghostscript" ,ghostscript)
("libjpeg" ,libjpeg)
@@ -64,6 +68,7 @@
'configure
(lambda _
(copy-file "config.mk.in" "config.mk")
+ (chmod "config.mk" #o664)
(let ((f (open-file "config.mk" "a")))
(display "CC=gcc\n" f)
(display "CFLAGS_SHLIB += -fPIC\n" f)