summaryrefslogtreecommitdiff
path: root/gnu/packages/ncurses.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 17:26:01 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 19:29:12 +0100
commit5170bbd5bcbcdacff517641ac19b3ba8c2205c5e (patch)
treef58337c76083b9149d8d4c7e8a0b34304187f3b2 /gnu/packages/ncurses.scm
parente9190dd4c4eeaf66472ac480386f96bf3be92b4d (diff)
downloadguix-patches-5170bbd5bcbcdacff517641ac19b3ba8c2205c5e.tar
guix-patches-5170bbd5bcbcdacff517641ac19b3ba8c2205c5e.tar.gz
gnu: ncurses: Update phase style.
* gnu/packages/ncurses.scm (ncurses)[arguments]: Use INVOKE and end phases with #t.
Diffstat (limited to 'gnu/packages/ncurses.scm')
-rw-r--r--gnu/packages/ncurses.scm30
1 files changed, 17 insertions, 13 deletions
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index 548261289e..4ddeef2d16 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -56,7 +56,8 @@
(let ((patch-makefile-phase
'(lambda _
(for-each patch-makefile-SHELL
- (find-files "." "Makefile.in"))))
+ (find-files "." "Makefile.in"))
+ #t))
(configure-phase
;; The 'configure' script does not understand '--docdir', so we must
;; override that and use '--mandir' instead.
@@ -64,21 +65,23 @@
#:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
(doc (assoc-ref outputs "doc")))
- (zero? (apply system* "./configure"
- (string-append "SHELL=" (which "sh"))
- (string-append "--build=" build)
- (string-append "--prefix=" out)
- (string-append "--mandir=" doc "/share/man")
- (if target
- (cons (string-append "--host=" target)
- configure-flags)
- configure-flags))))))
+ (apply invoke "./configure"
+ (string-append "SHELL=" (which "sh"))
+ (string-append "--build=" build)
+ (string-append "--prefix=" out)
+ (string-append "--mandir=" doc "/share/man")
+ (if target
+ (cons (string-append "--host=" target)
+ configure-flags)
+ configure-flags))
+ #t)))
(apply-rollup-patch-phase
'(lambda* (#:key inputs native-inputs #:allow-other-keys)
(copy-file (assoc-ref (or native-inputs inputs) "rollup-patch")
(string-append (getcwd) "/rollup-patch.sh.bz2"))
- (and (zero? (system* "bzip2" "-d" "rollup-patch.sh.bz2"))
- (zero? (system* "sh" "rollup-patch.sh")))))
+ (invoke "bzip2" "-d" "rollup-patch.sh.bz2")
+ (invoke "sh" "rollup-patch.sh")
+ #t))
(remove-shebang-phase
'(lambda _
;; To avoid retaining a reference to the bootstrap Bash via the
@@ -149,7 +152,8 @@
(when (file-exists? packagew.pc)
(symlink packagew.pc package.pc))))
'())))
- '("curses" "ncurses" "form" "panel" "menu")))))))
+ '("curses" "ncurses" "form" "panel" "menu")))
+ #t))))
`(#:configure-flags
,(cons*
'quasiquote