summaryrefslogtreecommitdiff
path: root/gnu/packages/ncurses.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-24 00:01:38 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:37 -0500
commit44298269baae6cb8bbaa19e504f391c74cf5729b (patch)
tree859d75de6ceb87420271eb4969f4f4f025997dec /gnu/packages/ncurses.scm
parent99fffa8ae08264b1c41ddaa9e7f745dcb621b398 (diff)
downloadguix-patches-44298269baae6cb8bbaa19e504f391c74cf5729b.tar
guix-patches-44298269baae6cb8bbaa19e504f391c74cf5729b.tar.gz
gnu: Add dialog.
* gnu/packages/python.scm (dialog): New variable.
Diffstat (limited to 'gnu/packages/ncurses.scm')
-rw-r--r--gnu/packages/ncurses.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index 2b0d442664..b7fbfc982d 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -110,3 +111,27 @@ implement user interfaces for command-line applications. The accompanying
ncursesw library provides wide character support.")
(license x11)
(home-page "http://www.gnu.org/software/ncurses/"))))
+
+(define-public dialog
+ (package
+ (name "dialog")
+ (version "1.2-20150920")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://invisible-mirror.net/archives/dialog/dialog-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "01ccd585c241nkj02n0zdbx8jqhylgcfpcmmshynh0c7fv2ixrn4"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ; no test suite
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (synopsis "Curses widgets")
+ (description "Dialog is a script-interpreter which provides a set of
+curses widgets, such as dialog boxes.")
+ (home-page "http://invisible-island.net/dialog/dialog.html")
+ ;; Includes the gpl3 file "config.sub" from Automake.
+ (license (list lgpl2.1 gpl3))))