summaryrefslogtreecommitdiff
path: root/gnu/packages/ncurses.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-18 16:54:45 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-20 23:56:58 +0200
commit1bd364364dbbff2b51a7822b13bdbeecfd9f2d34 (patch)
treecc11df5304c91e3119954edee39118e9c3976498 /gnu/packages/ncurses.scm
parent2b5e412b30f5d3fb66ee4f697629e86d536ff5a0 (diff)
downloadguix-patches-1bd364364dbbff2b51a7822b13bdbeecfd9f2d34.tar
guix-patches-1bd364364dbbff2b51a7822b13bdbeecfd9f2d34.tar.gz
gnu: ncurses: Update to 6.1-20190909.
* gnu/packages/ncurses.scm (ncurses): Update to 6.1-20190609. [arguments]: Reinstate 'apply-rollup-patch' phase. Move 'remove-unneeded-shebang' phase later to prevent conflict with patch. [native-inputs]: Add "rollup-patch" origin.
Diffstat (limited to 'gnu/packages/ncurses.scm')
-rw-r--r--gnu/packages/ncurses.scm23
1 files changed, 18 insertions, 5 deletions
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index a35ff9b400..78e9ba1377 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 ng0 <ng0@n0.is>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -40,7 +40,7 @@
(define-public ncurses
(package
(name "ncurses")
- (version "6.1")
+ (version "6.1-20190609")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/ncurses/ncurses-"
@@ -84,8 +84,7 @@
(copy-file (assoc-ref (or native-inputs inputs) "rollup-patch")
(string-append (getcwd) "/rollup-patch.sh.bz2"))
(invoke "bzip2" "-d" "rollup-patch.sh.bz2")
- (invoke "sh" "rollup-patch.sh")
- #t))
+ (invoke "sh" "rollup-patch.sh")))
(remove-shebang-phase
'(lambda _
;; To avoid retaining a reference to the bootstrap Bash via the
@@ -189,17 +188,31 @@
,@(if (target-mingw?) '("--enable-term-driver") '()))))
#:tests? #f ; no "check" target
#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'apply-rollup-patch
+ ,apply-rollup-patch-phase)
(replace 'configure ,configure-phase)
(add-after 'install 'post-install
,post-install-phase)
(add-before 'configure 'patch-makefile-SHELL
,patch-makefile-phase)
- (add-after 'unpack 'remove-unneeded-shebang
+ (add-before 'patch-source-shebangs 'remove-unneeded-shebang
,remove-shebang-phase)))))
(native-inputs
`(,@(if (%current-target-system)
`(("self" ,this-package)) ;for `tic'
'())
+
+ ("rollup-patch"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append
+ "https://invisible-mirror.net/archives/ncurses/"
+ (car (string-split version #\-))
+ "/ncurses-" version "-patch.sh.bz2"))
+ (sha256
+ (base32
+ "0hqlqdqmh7lfs6dwj763qksb4j9nk0pv6crzx5gnp6n4caz3i46g"))))
+
("pkg-config" ,pkg-config)))
(native-search-paths
(list (search-path-specification