summaryrefslogtreecommitdiff
path: root/gnu/packages/nano.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-02 12:39:26 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-02 12:39:26 +0200
commit1a10cefc91cc954ef62ca069c02a35031deb4944 (patch)
treeff67891b455796a00733f8b66e5b843d75ee38d5 /gnu/packages/nano.scm
parent47ddf3e5f07351c738d6199a0df540d193d14e31 (diff)
downloadguix-patches-1a10cefc91cc954ef62ca069c02a35031deb4944.tar
guix-patches-1a10cefc91cc954ef62ca069c02a35031deb4944.tar.gz
gnu: nano: Update to 2.7.5.
* gnu/packages/nano.scm (nano): Update to 2.7.5. [description]: Updated with help from 'guix lint'.
Diffstat (limited to 'gnu/packages/nano.scm')
-rw-r--r--gnu/packages/nano.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/nano.scm b/gnu/packages/nano.scm
index 5fafe78e2e..571770b459 100644
--- a/gnu/packages/nano.scm
+++ b/gnu/packages/nano.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
@@ -29,7 +29,7 @@
(define-public nano
(package
(name "nano")
- (version "2.7.4")
+ (version "2.7.5")
(source
(origin
(method url-fetch)
@@ -37,7 +37,7 @@
version ".tar.gz"))
(sha256
(base32
- "135wzlv77p9za8679j2jpfkpvainvyagrhkdxngp71ynabgc5zr3"))))
+ "01yrh66rph0vn9q9r2d2jji5yzaakxrj75j9fsm0g41m8qpy4sr2"))))
(build-system gnu-build-system)
(inputs
`(("gettext" ,gettext-minimal)
@@ -45,7 +45,8 @@
(home-page "https://www.nano-editor.org/")
(synopsis "Small, user-friendly console text editor")
(description
- "GNU Nano is a small and simple text editor. In addition to basic
-editing, it supports interactive search and replace, go to line and column
-number, auto-indentation and more.")
+ "GNU nano is a small and simple text editor for use in a terminal. Besides
+basic editing, it supports: undo/redo, syntax highlighting, spell checking,
+justifying, auto-indentation, bracket matching, interactive search-and-replace
+(with regular expressions), and the editing of multiple files.")
(license gpl3+))) ; some files are under GPLv2+