summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-09 21:53:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-14 00:24:42 -0400
commitea0a51071e68c37a4c9c25421cf03bc2f442c67b (patch)
treec30587b862169414a2170b86aae6ba4dbc5a2796 /gnu/packages/music.scm
parent0b5120fb03db5226871b3482a72b1e6fdaa59ead (diff)
downloadguix-patches-ea0a51071e68c37a4c9c25421cf03bc2f442c67b.tar
guix-patches-ea0a51071e68c37a4c9c25421cf03bc2f442c67b.tar.gz
gnu: Rename qtbase to qtbase-5.
This change was automated via the following command: $ git ls-files | xargs sed -i 's/,qtbase)/,qtbase-5)/g' $ git ls-files | xargs sed -i 's/inherit qtbase)/inherit qtbase-5)/g' $ git ls-files | xargs sed -i 's/package-version qtbase)/package-version qtbase-5)/g' $ git checkout etc # to clear some spurious changes This is done so the qtbase package can be upgraded to version 6 in the following commit.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 68d48a2937..c9b949d0c3 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -231,7 +231,7 @@
("pkg-config" ,pkg-config)))
(inputs
`(("dbus" ,dbus)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtmultimedia" ,qtmultimedia)
;; Plugin dependencies
("alsa-lib" ,alsa-lib)
@@ -434,7 +434,7 @@ score, keyboard, guitar, drum and controller views.")
("libxml2" ,libxml2)
("protobuf" ,protobuf)
("pulseaudio" ,pulseaudio)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtx11extras" ,qtx11extras)
("sqlite" ,sqlite)
("sparsehash" ,sparsehash)
@@ -527,7 +527,7 @@ playing your music.")
("libmtp" ,libmtp)
("protobuf" ,protobuf)
("pulseaudio" ,pulseaudio)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtx11extras" ,qtx11extras)
("sqlite" ,sqlite)
("taglib" ,taglib)))
@@ -759,7 +759,7 @@ settings (aliasing, linear interpolation and cubic interpolation).")
("libsndfile" ,libsndfile)
("lrdf" ,lrdf)
("pulseaudio" ,pulseaudio)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtxmlpatterns" ,qtxmlpatterns)
("zlib" ,zlib)))
(home-page "http://www.hydrogen-music.org")
@@ -1999,7 +1999,7 @@ your own lessons.")
("boost" ,boost)
("minizip" ,minizip)
("pugixml" ,pugixml)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("rapidjson" ,rapidjson)
("rtmidi" ,rtmidi)
("timidity" ,timidity++)
@@ -2082,7 +2082,7 @@ users to select LV2 plugins and run them with jalv.")
("alsa-lib" ,alsa-lib)
("non-session-manager" ,non-session-manager)
("liblo" ,liblo)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
@@ -2115,7 +2115,7 @@ oscillators and stereo effects.")
("alsa-lib" ,alsa-lib)
("non-session-manager" ,non-session-manager)
("liblo" ,liblo)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
@@ -2148,7 +2148,7 @@ effects.")
("alsa-lib" ,alsa-lib)
("non-session-manager" ,non-session-manager)
("liblo" ,liblo)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
@@ -2181,7 +2181,7 @@ effects.")
("non-session-manager" ,non-session-manager)
("liblo" ,liblo)
("fftwf" ,fftwf)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)))
@@ -2761,7 +2761,7 @@ browser.")
"/manpages/docbook.xsl")))
#t)))))
(inputs
- `(("qtbase" ,qtbase)
+ `(("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)
("qttools" ,qttools)
("alsa-lib" ,alsa-lib)))
@@ -2809,7 +2809,7 @@ backends, including ALSA, OSS, Network and FluidSynth.")
#t)))))
(inputs
`(("drumstick" ,drumstick)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)
("qtx11extras" ,qtx11extras)))
(native-inputs
@@ -3149,7 +3149,7 @@ from the command line.")
(arguments
`(#:tests? #f)) ; no "check" target
(inputs
- `(("qt" ,qtbase)
+ `(("qt" ,qtbase-5)
("qtx11extras" ,qtx11extras)
("alsa-lib" ,alsa-lib)
("jack" ,jack-1)
@@ -4467,7 +4467,7 @@ develop custom plugins for use in other applications without programming.")
`(#:configure-flags
(list "--enable-qt5")))
(inputs
- `(("qtbase" ,qtbase)
+ `(("qtbase" ,qtbase-5)
("alsa-lib" ,alsa-lib)
("jack" ,jack-1)
("liblo" ,liblo)
@@ -4498,7 +4498,7 @@ modules running in parallel.")
`(#:configure-flags
(list "--enable-qt5")))
(inputs
- `(("qtbase" ,qtbase)
+ `(("qtbase" ,qtbase-5)
("alsa-lib" ,alsa-lib)))
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -4681,7 +4681,7 @@ are a C compiler and glib. Full API documentation and examples are included.")
"0g9pls46iggg7rdm65vzfj8nyr3v2n5xkp54c4qbh9hhalpsw4ay"))))))
(inputs
`(("sdl" ,sdl)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtx11extras" ,qtx11extras)
("fltk" ,fltk)
("libogg" ,libogg)
@@ -4786,7 +4786,7 @@ standalone JACK client and an LV2 plugin is also available.")
("portaudio" ,portaudio)
("portmidi" ,portmidi)
("pulseaudio" ,pulseaudio)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
("qtgraphicaleffects" ,qtgraphicaleffects)
("qtquickcontrols2" ,qtquickcontrols2)
@@ -4864,7 +4864,7 @@ sample library.")
("lv2" ,lv2)
("pcre" ,pcre)
("pulseaudio" ,pulseaudio) ; required by rtaudio
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtsvg" ,qtsvg)
("rtaudio" ,rtaudio)
("rubberband" ,rubberband)
@@ -5056,7 +5056,7 @@ specification and header.")
("libsamplerate" ,libsamplerate)
("lilypond" ,lilypond)
("lrdf" ,lrdf)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("tar" ,tar)
("lirc" ,lirc)
("wavpack" ,wavpack)
@@ -5162,7 +5162,7 @@ the electronic or dubstep genre.")
`(("alsa-lib" ,alsa-lib)
("drumstick" ,drumstick)
("pulseaudio" ,pulseaudio)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "https://github.com/pedrolcl/Linux-SonivoxEas")
@@ -5546,7 +5546,7 @@ discard bad quality ones.
("fftw" ,fftw)
("jack" ,jack-1)
("portaudio" ,portaudio)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtmultimedia" ,qtmultimedia)
("qtsvg" ,qtsvg)))
(native-inputs