summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-11-15 09:31:11 +0000
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-15 14:29:57 +0100
commitbcdf11d6ffd8cc55653ff0257f7a832aaa385c60 (patch)
tree0dfb4c76bd77d07b2a18645c6637b09f6ec9a47e /gnu/packages/music.scm
parentae5525c59114e54698c3e24e1a672ad333153a96 (diff)
downloadguix-patches-bcdf11d6ffd8cc55653ff0257f7a832aaa385c60.tar
guix-patches-bcdf11d6ffd8cc55653ff0257f7a832aaa385c60.tar.gz
gnu: rtmidi: Update to 4.0.0.
* gnu/packages/audio.scm (rtmidi): Update to 4.0.0. [source]: Download tarball from upstream URL rather than the powertab github fork. [arguments]: Enable tests. Remove 'build and 'install phases and add a new 'noconfigure phase to prevent the bootstrap script from invoking configure. [home-page]: Update homepage to upstream URL. * gnu/packages/music.scm (powertabeditor)[arguments]: Add phase that substitutes the rtmidi #include directive to find the header. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 3373b4c0a3..241ede58d8 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1284,6 +1284,14 @@ add_library( rapidjson INTERFACE IMPORTED )"))
(("#include <QWidget>" m)
(string-append m "\n#include <QButtonGroup>\n#include <QAction>")))
#t))
+ ;; FIXME: Finding RtMidi was fixed upstream so we should be able to
+ ;; remove this hack when a release is made.
+ ;; See https://github.com/powertab/powertabeditor/issues/255
+ (add-after 'unpack 'fix-rtmidi-header
+ (lambda _
+ (substitute* "source/audio/midioutputdevice.cpp"
+ (("#include <RtMidi.h>") "#include <rtmidi/RtMidi.h>"))
+ #t))
(add-before 'configure 'remove-third-party-libs
(lambda* (#:key inputs #:allow-other-keys)
;; Link with required static libraries, because we're not