summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRovanion Luckey <rovanion.luckey@gmail.com>2021-05-28 17:19:56 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-30 11:53:00 +0200
commitae303853d447018a98d0ec7663ccde969d87302d (patch)
tree6cf93c490e942877c6d2311f480bfcd4c8d28e22 /gnu/packages/music.scm
parent237b744d23254c28123f6bf48b6e5e9e5c33438a (diff)
downloadguix-patches-ae303853d447018a98d0ec7663ccde969d87302d.tar
guix-patches-ae303853d447018a98d0ec7663ccde969d87302d.tar.gz
gnu: Add lingot.
* gnu/packages/music.scm (lingot): New public variable. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index fb15a6ea84..ed64d70a0b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
+;;; Copyright © 2021 Rovanion Luckey <rovanion.luckey@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1340,6 +1341,47 @@ Sega Master System/Mark III, Sega Genesis/Mega Drive, BBC Micro
;; demo and player directories are under the Expat license
license:expat))))
+(define-public lingot
+ (package
+ (name "lingot")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ibancg/lingot")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04lcjzfhddbyskxr2068z609y6x0s2gjx1wl78w0dkxdi459zrn9"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("cunit" ,cunit)
+ ("glib" ,glib "bin") ; for glib-compile-resources
+ ("intltool" ,intltool)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("fftw" ,fftw)
+ ("gtk+" ,gtk+)
+ ("jack" ,jack-2)
+ ("json-c" ,json-c)
+ ("pulseaudio" ,pulseaudio)))
+ (home-page "http://lingot.nongnu.org/")
+ (synopsis "Accurate & configurable musical instrument tuner")
+ (description
+ "LINGOT is a musical instrument tuner. It's accurate, easy to use, and
+highly configurable. Originally conceived to tune electric guitars, it can now
+be used to tune other instruments.
+
+It looks like an analogue tuner, with a gauge indicating the relative shift to a
+certain note, determined automatically as the closest note to the estimated
+frequency.")
+ (license license:gpl2+)))
+
(define-public ninjas2
(package
(name "ninjas2")