summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-10 03:38:28 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-10 04:37:24 +0200
commit98f08a99c6a0fefeca043cfac1fd89be8deebe5f (patch)
treeb4eda539d30ae23ff292b3112348e85438ddd713 /gnu/packages/music.scm
parent7801e9f2d4c6761593a9078d5ef019be8f350396 (diff)
downloadguix-patches-98f08a99c6a0fefeca043cfac1fd89be8deebe5f.tar
guix-patches-98f08a99c6a0fefeca043cfac1fd89be8deebe5f.tar.gz
gnu: pd: Don't hard-code Tk version.
* gnu/packages/music.scm (pd)[arguments]: Construct the wish file name from the tk package version.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f22207579f..beecdcc670 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1892,20 +1892,22 @@ export.")
"0dz6r6jy0zfs1xy1xspnrxxks8kddi9c7pxz4vpg2ygwv83ghpg5"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no "check" target
- #:configure-flags
- (list
- "--enable-jack"
- (string-append "--with-wish=" (string-append
- (assoc-ref %build-inputs "tk")
- "/bin/wish8.6")))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'fix-with-path
- (lambda _
- (substitute* "tcl/pd-gui.tcl"
- (("exec wish ") (string-append "exec " (which "wish8.6") " ")))
- #t)))))
+ (let ((wish (string-append "wish" (version-major+minor
+ (package-version tk)))))
+ `(#:tests? #f ; no "check" target
+ #:configure-flags
+ (list
+ "--enable-jack"
+ (string-append "--with-wish=" (string-append
+ (assoc-ref %build-inputs "tk")
+ "/bin/" ,wish)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'fix-with-path
+ (lambda _
+ (substitute* "tcl/pd-gui.tcl"
+ (("exec wish ") (string-append "exec " (which ,wish) " ")))
+ #t))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)