summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2021-02-02 08:40:33 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-08 11:17:11 +0100
commit92f37c07e7d1c2c528560609787157bf67c50c1b (patch)
treec7f7b82f403022ec22a64279002941d8df979856 /gnu/packages/music.scm
parent7b207e08492998bb91ac99f703f193d32dfee31e (diff)
downloadguix-patches-92f37c07e7d1c2c528560609787157bf67c50c1b.tar
guix-patches-92f37c07e7d1c2c528560609787157bf67c50c1b.tar.gz
gnu: clementine: Indent.
* gnu/packages/music.scm (clementine): Remove 'version' variable and one level of indentation. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm205
1 files changed, 102 insertions, 103 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a39f9fc3d9..3da44e8fe7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -338,111 +338,110 @@ score, keyboard, guitar, drum and controller views.")
(license license:gpl3+)))
(define-public clementine
- (let ((version "1.4.0rc1-450-g2725ef99d"))
- (package
- (name "clementine")
- (version version)
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/clementine-player/Clementine")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1pcwwi9b2qcfjn748577gqx6d1hgg7cisw2dn43npwafdvvkdb90"))
- (modules '((guix build utils)
- (ice-9 regex)))
- (snippet
- '(begin
- (use-modules ((ice-9 regex)))
- (for-each
- (lambda (dir)
- ;; TODO: The following dependencies are still bundled:
- ;; - "qxt": Appears to be unmaintained upstream.
- ;; - "qsqlite"
- ;; - "qtsingleapplication"
- ;; - "qocoa"
- ;; - "qtiocompressor"
- (let ((bundled '("qsqlite"
- "qtsingleapplication"
- "qxt"
- "qocoa"
- "qtiocompressor")))
- (if (not
- (string-match
- (string-append ".?*(" (string-join bundled "|") ")")
- dir))
- (delete-file-recursively dir))))
- (find-files "3rdparty"
- (lambda (file stat)
- (string-match "^3rdparty/[^/]*$" file))
- #:directories? #t))
- #t))))
- (build-system cmake-build-system)
- (arguments
- '(#:test-target "clementine_test"
- #:configure-flags
- (list ;; Requires unpackaged "projectm"
- "-DENABLE_VISUALISATIONS=OFF"
- ;; Otherwise it may try to download a non-free library at run-time.
- ;; TODO In an origin snippet, remove the code that performs the
- ;; download.
- "-DHAVE_SPOTIFY_DOWNLOADER=FALSE"
- ;; Clementine checks that the taglib version is higher than 1.11,
- ;; because of https://github.com/taglib/taglib/issues/864. Remove
- ;; this flag when 1.12 is released.
- "-DUSE_SYSTEM_TAGLIB=TRUE")
- #:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
- (wrap-program (string-append out "/bin/clementine")
- `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))
- #t))))))
- (native-inputs
- `(("gettext" ,gettext-minimal)
- ("googletest" ,googletest)
- ("pkg-config" ,pkg-config)
- ("qtlinguist" ,qttools)))
- (inputs
- `(("boost" ,boost)
- ("chromaprint" ,chromaprint)
- ("fftw" ,fftw)
- ("glib" ,glib)
- ("glu" ,glu)
- ("gstreamer" ,gstreamer)
- ("gst-plugins-base" ,gst-plugins-base)
- ("gst-plugins-good" ,gst-plugins-good)
- ("gst-libav" ,gst-libav)
- ("libcdio" ,libcdio)
- ("libmygpo-qt" ,libmygpo-qt)
- ;; TODO: Package libgpod.
- ("libmtp" ,libmtp)
- ("libxml2" ,libxml2)
- ("protobuf" ,protobuf)
- ("pulseaudio" ,pulseaudio)
- ("qtbase" ,qtbase)
- ("qtx11extras" ,qtx11extras)
- ("sqlite" ,sqlite)
- ("sparsehash" ,sparsehash)
- ("taglib" ,taglib)))
- (home-page "https://clementine-player.org")
- (synopsis "Music player and library organizer")
- (description "Clementine is a multiplatform music player. It is inspired
+ (package
+ (name "clementine")
+ (version "1.4.0rc1-450-g2725ef99d")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/clementine-player/Clementine")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pcwwi9b2qcfjn748577gqx6d1hgg7cisw2dn43npwafdvvkdb90"))
+ (modules '((guix build utils)
+ (ice-9 regex)))
+ (snippet
+ '(begin
+ (use-modules ((ice-9 regex)))
+ (for-each
+ (lambda (dir)
+ ;; TODO: The following dependencies are still bundled:
+ ;; - "qxt": Appears to be unmaintained upstream.
+ ;; - "qsqlite"
+ ;; - "qtsingleapplication"
+ ;; - "qocoa"
+ ;; - "qtiocompressor"
+ (let ((bundled '("qsqlite"
+ "qtsingleapplication"
+ "qxt"
+ "qocoa"
+ "qtiocompressor")))
+ (if (not
+ (string-match
+ (string-append ".?*(" (string-join bundled "|") ")")
+ dir))
+ (delete-file-recursively dir))))
+ (find-files "3rdparty"
+ (lambda (file stat)
+ (string-match "^3rdparty/[^/]*$" file))
+ #:directories? #t))
+ #t))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:test-target "clementine_test"
+ #:configure-flags
+ (list ;; Requires unpackaged "projectm"
+ "-DENABLE_VISUALISATIONS=OFF"
+ ;; Otherwise it may try to download a non-free library at run-time.
+ ;; TODO In an origin snippet, remove the code that performs the
+ ;; download.
+ "-DHAVE_SPOTIFY_DOWNLOADER=FALSE"
+ ;; Clementine checks that the taglib version is higher than 1.11,
+ ;; because of https://github.com/taglib/taglib/issues/864. Remove
+ ;; this flag when 1.12 is released.
+ "-DUSE_SYSTEM_TAGLIB=TRUE")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH")))
+ (wrap-program (string-append out "/bin/clementine")
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path)))
+ #t))))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("googletest" ,googletest)
+ ("pkg-config" ,pkg-config)
+ ("qtlinguist" ,qttools)))
+ (inputs
+ `(("boost" ,boost)
+ ("chromaprint" ,chromaprint)
+ ("fftw" ,fftw)
+ ("glib" ,glib)
+ ("glu" ,glu)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("gst-plugins-good" ,gst-plugins-good)
+ ("gst-libav" ,gst-libav)
+ ("libcdio" ,libcdio)
+ ("libmygpo-qt" ,libmygpo-qt)
+ ;; TODO: Package libgpod.
+ ("libmtp" ,libmtp)
+ ("libxml2" ,libxml2)
+ ("protobuf" ,protobuf)
+ ("pulseaudio" ,pulseaudio)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)
+ ("sqlite" ,sqlite)
+ ("sparsehash" ,sparsehash)
+ ("taglib" ,taglib)))
+ (home-page "https://clementine-player.org")
+ (synopsis "Music player and library organizer")
+ (description "Clementine is a multiplatform music player. It is inspired
by Amarok 1.4, focusing on a fast and easy-to-use interface for searching and
playing your music.")
- (license (list
- ;; clementine and qtiocompressor are under GPLv3.
- license:gpl3+
- ;; qxt is under CPL1.0.
- license:cpl1.0
- ;; qsqlite and qtsingleapplication are under LGPL2.1+.
- license:lgpl2.1+
- ;; qocoa is under MIT and CC by-sa for the icons.
- license:cc-by-sa3.0)))))
+ (license (list
+ ;; clementine and qtiocompressor are under GPLv3.
+ license:gpl3+
+ ;; qxt is under CPL1.0.
+ license:cpl1.0
+ ;; qsqlite and qtsingleapplication are under LGPL2.1+.
+ license:lgpl2.1+
+ ;; qocoa is under MIT and CC by-sa for the icons.
+ license:cc-by-sa3.0))))
(define-public cmus
(package