summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorSughosha <sughosha@proton.me>2022-07-01 17:53:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-07-01 19:08:46 +0200
commit697e75fca59dedfad6cfef4162fff5ab121e940c (patch)
treebd4a6f7980a3c50bb81b74ab3998266e4eb3332c /gnu/packages/music.scm
parent3b19dbd703685c3457e4ab997076009175927a7a (diff)
downloadguix-patches-697e75fca59dedfad6cfef4162fff5ab121e940c.tar
guix-patches-697e75fca59dedfad6cfef4162fff5ab121e940c.tar.gz
gnu: Add fabla.
* gnu/packages/music.scm (fabla): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e337372c2a..912f34043f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5055,6 +5055,34 @@ kit. It provides a patch bay in flow matrix style for audio, MIDI, CV, and
OSC connections.")
(license license:artistic2.0)))
+(define-public fabla
+ (let ((revision "1")
+ ;; The last release was in 2016. Since then a number of commits have
+ ;; been added to fix build problems.
+ (commit "10acf03046d980f96ed192d5acb9deb812f5c639"))
+ (package
+ (name "fabla")
+ (version (git-version "1.3.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openAVproductions/openAV-Fabla")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ybbzb86j1n5dfhzc6aa3cibkwi6q3x0c18b1w3anyibanmr1wmc"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ;there are none
+ (inputs (list ntk cairomm libsndfile))
+ (native-inputs (list pkg-config lv2 mesa))
+ (home-page "http://openavproductions.com/fabla/")
+ (synopsis "Sampler LV2 plugin")
+ (description
+ "Fabla is an LV2 drum sampler plugin instrument. It is ideal for loading up
+your favorite sampled sounds and bashing away on a MIDI controller.")
+ (license license:gpl2+))))
+
(define-public sorcer
(let ((revision "1")
;; The last release was in 2016. Since then a couple of commits have